GeezerVisonThe World Wide Web, restored to 800 pixels of glory. |
| Home|About|Gaming cabinet|Archives|How it works|Starter sites |
GeezerVison is showing en.wikipedia.org — List of HTTP header fields - Wikipedia (Redirected from HTTP response header field)
This article lists standard and notable non-standard HTTP header fields. A core set of fields is standardized by the Internet Engineering Task Force (IETF) in RFC 9110 and 9111. The Field Names, Header Fields and Repository of Provisional Registrations are maintained by the IANA. Additional fields may be defined by a web application. In the past, non-standard header field names were prefixed with A few field values can contain comments (i.e. in User-Agent, Server, Via fields), which can be ignored by software.[3] Many field values may contain a quality (q) key-value pair separated by equals sign, specifying a weight to use in content negotiation.[4] For example, a browser may indicate that it accepts information in German or English, with German as preferred by setting the q value for
Request fieldsThis section lists header fields used in a request. Standard request fieldsA-IM[RFC 3229, permanent] Acceptable instance-manipulations for the request.[5] For example: Accept[RFC 9110, permanent] Media type(s) that is/are acceptable for the response. See Content negotiation. For example: Accept-Charset[RFC 9110, permanent] Character sets that are acceptable. For example: Accept-Datetime[RFC 7089, provisional] Acceptable version in time. For example: Accept-Encoding[RFC 9110, permanent] List of acceptable encodings. See HTTP compression. For example: Accept-Language[RFC 9110, permanent] List of acceptable human languages for response. See Content negotiation. For example: Access-Control-Request-Method, Access-Control-Request-Headers[permanent] Initiates a request for cross-origin resource sharing with Origin (below).[6] For example: Authorization[RFC 9110, permanent] Authentication credentials for HTTP authentication. For example: Cache-ControlSee also: Cache-Control
[RFC 9111, permanent] Used to specify directives that must be obeyed by all caching mechanisms along the request-response chain. Per HTTP/1.1, the The behavior of For example: Connection[RFC 9110, permanent] Control options for the current connection and list of hop-by-hop request fields.[9] Must not be used with HTTP/2.[10] For example: Content-Digest[RFC 9530, Digest Fields][11] Content-Digest header enables verification of message content integrity by computing a digest over the literal bytes transmitted in the HTTP message. This digest reflects the content after applying transformations like Content-Encoding, matching exactly what travels across the network. Content-Encoding[RFC 9110, permanent] The type of encoding used on the data. See HTTP compression. For example: Content-Length[RFC 9110, permanent] The length of the request body in octets (8-bit bytes). For example: Content-MD5[RFC 1544, 1864, 4021, obsolete] A Base64-encoded binary MD5 sum of the content of the request body.[12] For example: Content-Type[RFC 9110, permanent] The Media type of the body of the request (used with POST and PUT requests). For example: Cookie[RFC 2965, 6265, permanent] An HTTP cookie previously sent by the server with For example: Date[RFC 9110, permanent] The date and time at which the message was originated (in "HTTP-date" format as defined by RFC 9110: HTTP Semantics, section 5.6.7 "Date/Time Formats"). For example: Expect[RFC 9110, permanent] Indicates that particular server behaviors are required by the client. For example: Forwarded[RFC 7239, permanent] Disclose original information of a client connecting to a web server through an HTTP proxy.[13] For example: From[RFC 9110, permanent] The email address of the user making the request. For example: Host[RFC 9110, 9113, permanent] The domain name of the server (for virtual hosting), and the TCP port number on which the server is listening. The port number may be omitted if the port is the standard port for the service requested. Mandatory since HTTP/1.1.[14] If the request is generated directly in HTTP/2, it should not be used.[15] For example: HTTP2-Settings[RFC 7540, 9113, obsolete] A request that upgrades from HTTP/1.1 to HTTP/2 MUST include exactly one For example: If-Match[RFC 9110, permanent] Only perform the action if the client supplied entity matches the same entity on the server. This is mainly for methods like PUT to only update a resource if it has not been modified since the user last updated it. For example: If-Modified-Since[RFC 9110, permanent] Allows a 304 Not Modified to be returned if content is unchanged. For example: If-None-Match[RFC 9110, permanent] Allows a 304 Not Modified to be returned if content is unchanged, see HTTP ETag. For example: If-Range[RFC 9110, permanent] If the entity is unchanged, send me the part(s) that I am missing; otherwise, send me the entire new entity. For example: If-Unmodified-Since[RFC 9110, permanent] Only send the response if the entity has not been modified since a specific time. For example: Max-Forwards[RFC 9110, permanent] Limit the number of times the message can be forwarded through proxies or gateways. For example: Origin[RFC 6454, permanent] Initiates a request for cross-origin resource sharing (asks server for Access-Control-* response fields).[6] For example: Pragma[RFC 9111, outdated] Implementation-specific fields that may have various effects anywhere along the request-response chain. For example: Prefer[RFC 7240, permanent] Allows client to request that certain behaviors be employed by a server while processing a request. For example: Proxy-Authorization[RFC 9110, permanent] Authorization credentials for connecting to a proxy. For example: Range[RFC 9110, permanent] Request only part of an entity. Bytes are numbered from 0. See Byte serving. For example: Referer [sic]See also: HTTP referer
[RFC 9110, permanent] The address of the previous web page from which a link to the currently requested page was followed. Although the intended term is actually spelled "referrer", the misspelling is in the RFC as well as in most implementations, and is therefore considered correct terminology. For example: TE[RFC 9110, permanent] The transfer encodings the user agent is willing to accept: the same values as for the response header field Transfer-Encoding can be used, plus the "trailers" value (related to the "chunked" transfer method) to notify the server it expects to receive additional fields in the trailer after the last, zero-sized, chunk. Only For example: Trailer[RFC 9110, permanent] The Trailer general field value indicates that the given set of header fields is present in the trailer of a message encoded with chunked transfer coding. For example: Transfer-Encoding[RFC 9110, permanent] The form of encoding used to safely transfer the entity to the user. Currently defined methods are: chunked, compress, deflate, gzip, identity. Must not be used with HTTP/2.[10] For example: User-AgentSee also: User-Agent header
[RFC 9110, permanent] The user agent string of the user agent. For example: UpgradeSee also: Upgrade header
[RFC 9110, permanent] Ask the server to upgrade to another protocol. Must not be used in HTTP/2.[10] For example: Via[RFC 9110, permanent] Informs the server of proxies through which the request was sent. For example: Warning[RFC 7234, 9111, obsolete] A warning about a possible problem with the entity body.[18] Since this header is often neither sent by servers nor acknowledged by clients, this header and its codes were obsoleted by the HTTP Working Group in 2022 with RFC 9111.[19] The following caching related warning codes were specified under RFC 7234.[20][21]
For example: Common non-standard request fieldsUpgrade-Insecure-RequestsTells a server which (presumably in the middle of a HTTP -> HTTPS migration) hosts mixed content that the client would prefer redirection to HTTPS and can handle For example: X-Requested-WithMainly used to identify Ajax requests (most JavaScript frameworks send this field with value of For example: DNTSee also: Do Not Track
Requests a web application to disable their tracking of a user. This is Mozilla's version of the X-Do-Not-Track header field (since Firefox 4.0 Beta 11). Safari and IE9 also have support for this field.[24] On March 7, 2011, a draft proposal was submitted to IETF.[25] The W3C Tracking Protection Working Group is producing a specification.[26][27] For example:
X-Forwarded-ForSee also: X-Forwarded-For
A de facto standard for identifying the originating IP address of a client connecting to a web server through an HTTP proxy or load balancer. Superseded by Forwarded header.[28] For example:
X-Forwarded-HostA de facto standard for identifying the original host requested by the client in the For example:
X-Forwarded-ProtoA de facto standard for identifying the originating protocol of an HTTP request, since a reverse proxy (or a load balancer) may communicate with a web server using HTTP even if the request to the reverse proxy is HTTPS. An alternative form of the header (X-ProxyUser-Ip) is used by Google clients talking to Google servers. Superseded by Forwarded header.[30] For example: Front-End-HttpsNon-standard header field used by Microsoft applications and load-balancers.[31] For example: X-Http-Method-OverrideRequests a web application to override the method specified in the request (typically POST) with the method given in the header field (typically PUT or DELETE). This can be used when a user agent or firewall prevents PUT or DELETE methods from being sent directly (this is either a bug in the software component, which ought to be fixed, or an intentional configuration, in which case bypassing it may be the wrong thing to do).[32] For example: X-ATT-DeviceIdAllows easier parsing of the MakeModel/Firmware that is usually found in the User-Agent String of AT&T Devices.[33] For example: X-Wap-ProfileLinks to an XML file on the Internet with a full description and details about the device currently connecting. In the example to the right is an XML file for an AT&T Samsung Galaxy S2.[34] For example: Proxy-ConnectionImplemented as a misunderstanding of the HTTP specifications. Common because of mistakes in implementations of early HTTP versions. Has exactly the same functionality as standard Connection field. Must not be used with HTTP/2.[35][10] For example: X-UIDHServer-side deep packet inspection of a unique ID identifying customers of Verizon Wireless; also known as "perma-cookie" or "supercookie".[36][37][38] For example: X-Csrf-TokenUsed to prevent cross-site request forgery. Alternative header names are: For example: X-Request-ID, X-Correlation-ID, Correlation-IDCorrelates HTTP requests between a client and server. Superseded by the traceparent header.[stackoverflow2 1][42][43][44][45] For example: Save-DataThe Save-Data client hint request header available in Chrome, Opera, and Yandex browsers lets developers deliver lighter, faster applications to users who opt-in to data saving mode in their browser.[46][47] For example: Sec-GPCThe Sec-GPC (Global Privacy Control) request header indicates whether the user consents to a website or service selling or sharing their personal information with third parties.[48] For example: Response fieldsThis section lists header fields used in a response. Standard response fieldsAccept-CH[RFC 8942, experimental] Requests HTTP Client Hints. For example: Access-Control-Allow-Origin, Access-Control-Allow-Credentials, Access-Control-Expose-Headers, Access-Control-Max-Age, Access-Control-Allow-Methods, Access-Control-Allow-Headers[RFC 7480, permanent] Specifying which web sites can participate in cross-origin resource sharing.[6] For example: Accept-Patch[RFC 5789, permanent] Specifies which patch document formats this server supports.[49] For example: Accept-Ranges[RFC 9110, permanent] What partial content range types this server supports via byte serving. For example: Age[RFC 9111, permanent] The age the object has been in a proxy cache in seconds. For example: Allow[RFC 9110, permanent] Valid methods for a specified resource. To be used for a 405 Method not allowed. For example: Alt-Svc[RFC 7838, permanent] A server uses "Alt-Svc" header (meaning Alternative Services) to indicate that its resources can also be accessed at a different network location (host or port) or using a different protocol. When using HTTP/2, servers should instead send an ALTSVC frame.[50] For example: Cache-ControlSee also: Cache-Control
[RFC 9111, permanent] Tells all caching mechanisms from server to client whether they may cache the response. A numeric value is in seconds. If a web server responds with The value For example: Connection[RFC 9110, permanent] Control options for the current connection and list of hop-by-hop response fields.[9] Must not be used with HTTP/2.[10] For example: Content-Disposition[RFC 2616, 4021, 6266, permanent] An opportunity to raise a "File Download" dialogue box for a known MIME type with binary format or suggest a filename for dynamic content. Quotes are necessary with special characters.[51] For example: Content-Encoding[RFC 9110, permanent] The type of encoding used on the data. See HTTP compression. For example: Content-Language[RFC 9110, permanent] The natural language or languages of the intended audience for the enclosed content.[52] For example: Content-Length[RFC 9110, permanent] The length of the response body in octets (8-bit bytes). For example: Content-Location[RFC 9110, permanent] An alternate location for the returned data. For example: Content-MD5[RFC 1544, 1864, 4021, obsolete] A Base64-encoded binary MD5 sum of the content of the response.[12] For example: Content-Range[RFC 9110, permanent] Where in a full body message this partial message belongs. For example: Content-Type[RFC 9110, permanent] The MIME type of this content. For example: Date[RFC 9110, permanent] The date and time that the message was sent (in "HTTP-date" format as defined by RFC 9110). For example: Delta-Base[RFC 3229, permanent] Specifies the delta-encoding entity tag of the response.[5] For example: ETagSee also: HTTP ETag
[RFC 9110, permanent] An identifier for a specific version of a resource, often a message digest. For example: Expires[RFC 9111, permanent] Gives the date/time after which the response is considered stale (in "HTTP-date" format as defined by RFC 9110). For example: IM[RFC 3229, permanent] Instance-manipulations applied to the response.[5] For example: Last-Modified[RFC 9110, permanent] The last modified date for the requested object (in "HTTP-date" format as defined by RFC 9110). For example: Link[RFC 8288, permanent] Used to express a typed relationship with another resource, where the relation type is defined by RFC 8288.[53] For example: LocationSee also: HTTP location
[RFC 9110, permanent] Used in redirection, or when a new resource has been created. For example: For example: P3PSee also: P3P
[RFC 2626, permanent] This field is supposed to set P3P policy, in the form of For example: Pragma[RFC 9111, permanent] Implementation-specific fields that may have various effects anywhere along the request-response chain. For example: Preference-Applied[RFC 7240, permanent] Indicates which Prefer tokens were honored by the server and applied to the processing of the request. For example: Proxy-Authenticate[RFC 9110, permanent] Request authentication to access the proxy. For example: Public-Key-Pins[RFC 7469, permanent] HTTP Public Key Pinning, announces hash of website's authentic TLS certificate.[55] For example: Retry-After[RFC 9110, permanent] If an entity is temporarily unavailable, this instructs the client to try again later. Value could be a specified period of time (in seconds) or a HTTP-date.[56] For example 1: Server[RFC 9110, permanent] A name for the server. For example: Set-Cookie[RFC 6265, permanent] An HTTP cookie. For example: Strict-Transport-SecuritySee also: HTTP Strict Transport Security
[RFC 6797, permanent] A HSTS Policy informing the HTTP client how long to cache the HTTPS-only policy and whether this applies to subdomains. For example: Trailer[RFC 9110, permanent] The Trailer general field value indicates that the given set of header fields is present in the trailer of a message encoded with chunked transfer coding. For example: Transfer-Encoding[RFC 9110, permanent] The form of encoding used to safely transfer the entity to the user. Currently defined methods are: chunked, compress, deflate, gzip, identity. Must not be used with HTTP/2.[10] For example: Tk[RFC 2295, permanent] Tracking Status header, value suggested to be sent in response to a DNT (do-not-track) request. Possible values:
For example: UpgradeSee also: Upgrade header
[RFC 9110, permanent] Ask the client to upgrade to another protocol. Must not be used in HTTP/2.[10] For example: Vary[RFC 9110, permanent] Tells downstream proxies how to match future request headers to decide whether the cached response can be used rather than requesting a fresh one from the origin server. For example 1: Via[RFC 9110, permanent] Informs the client of proxies through which the response was sent. For example: Warning[RFC 7234, RFC 9111, obsolete] A general warning about possible problems with the entity body.[18] For example: WWW-Authenticate[RFC 9110, permanent] Indicates the authentication scheme that should be used to access the requested entity. For example: X-Frame-Options[RFC 7034, obsolete] Clickjacking protection: For example: Common non-standard response fieldsContent-Security-Policy, X-Content-Security-Policy, X-WebKit-CSPContent Security Policy definition.[58] For example:
Expect-CTNotify to prefer to enforce Certificate Transparency.[59] For example:
NELUsed to configure network request logging.[60] For example:
Permissions-PolicyTo allow or disable different features or APIs of the browser.[61] For example:
RefreshTells the browser to refresh the page or redirect to a different URL, either after a given number of seconds ( For example:
Report-ToInstructs the user agent to store reporting endpoints for an origin.[64] For example:
StatusCGI header field specifying the status of the HTTP response. Normal HTTP responses use a separate "Status-Line" instead, defined by RFC 9110.[65] For example:
Timing-Allow-OriginThe For example:
X-Content-DurationProvide the duration of the audio or video in seconds. Not supported by current browsers – the header was only supported by Gecko browsers, from which support was removed in 2015.[67][68] For example:
X-Content-Type-OptionsThe only defined value, "nosniff", prevents Internet Explorer from MIME-sniffing a response away from the declared content-type. This also applies to Google Chrome, when downloading extensions.[69][70] For example:
X-Powered-BySpecifies the technology (e.g. ASP.NET, PHP, JBoss) supporting the web application (version details are often in For example:
X-Redirect-BySpecifies the component that is responsible for a particular redirect.[72] For example:
X-Request-ID, X-Correlation-IDCorrelates HTTP requests between a client and server.[stackoverflow2 1] For example:
X-UA-CompatibleRecommends the preferred rendering engine (often a backward-compatibility mode) to use to display the content. Also used to activate Chrome Frame in Internet Explorer. In HTML Standard, only the For example:
X-XSS-ProtectionCross-site scripting (XSS) filter[75] For example:
See alsoReferences
As of this edit, this article uses content from "What is the X-REQUEST-ID http header?", authored by Stefan Kögl at Stack Exchange, which is licensed in a way that permits reuse under the Creative Commons Attribution-ShareAlike 3.0 Unported License, but not under the GFDL. All relevant terms must be followed.
As of this edit, this article uses content from "Why does ASP.NET framework add the 'X-Powered-By:ASP.NET' HTTP Header in responses?", authored by Adrian Grigore at Stack Exchange, which is licensed in a way that permits reuse under the Creative Commons Attribution-ShareAlike 3.0 Unported License, but not under the GFDL. All relevant terms must be followed.
External links
Hidden categories:
|
| You are visitor 01402503 — GeezerVison does not store the pages you look up. Best viewed with Netscape Navigator 4.7 or Internet Explorer 6 at 800×600. No cookies required. |