@@ -6039,6 +6039,9 @@ Throws an error if FIPS mode is not available. |
6039 | 6039 | <!-- YAML |
6040 | 6040 | added: v12.0.0 |
6041 | 6041 | changes: |
| 6042 | + - version: REPLACEME |
| 6043 | + pr-url: https://github.com/nodejs/node/pull/62474 |
| 6044 | + description: Add support for Ed25519 context parameter. |
6042 | 6045 | - version: v24.8.0 |
6043 | 6046 | pr-url: https://github.com/nodejs/node/pull/59570 |
6044 | 6047 | description: Add support for ML-DSA, Ed448, and SLH-DSA context parameter. |
@@ -6102,9 +6105,10 @@ additional properties can be passed: |
6102 | 6105 | `crypto.constants.RSA_PSS_SALTLEN_DIGEST` sets the salt length to the digest |
6103 | 6106 | size, `crypto.constants.RSA_PSS_SALTLEN_MAX_SIGN` (default) sets it to the |
6104 | 6107 | maximum permissible value. |
6105 | | -* `context` {ArrayBuffer|Buffer|TypedArray|DataView} For Ed448, ML-DSA, and SLH-DSA, |
6106 | | - this option specifies the optional context to differentiate signatures generated |
6107 | | - for different purposes with the same key. |
| 6108 | +* `context` {ArrayBuffer|Buffer|TypedArray|DataView} For Ed25519[^openssl32] |
| 6109 | + (using Ed25519ctx from [RFC 8032][]), Ed448, ML-DSA, and SLH-DSA, |
| 6110 | + this option specifies the optional context to differentiate signatures |
| 6111 | + generated for different purposes with the same key. |
6108 | 6112 |
|
6109 | 6113 | If the `callback` function is provided this function uses libuv's threadpool. |
6110 | 6114 |
|
@@ -6164,6 +6168,9 @@ not introduce timing vulnerabilities. |
6164 | 6168 | <!-- YAML |
6165 | 6169 | added: v12.0.0 |
6166 | 6170 | changes: |
| 6171 | + - version: REPLACEME |
| 6172 | + pr-url: https://github.com/nodejs/node/pull/62474 |
| 6173 | + description: Add support for Ed25519 context parameter. |
6167 | 6174 | - version: v24.8.0 |
6168 | 6175 | pr-url: https://github.com/nodejs/node/pull/59570 |
6169 | 6176 | description: Add support for ML-DSA, Ed448, and SLH-DSA context parameter. |
@@ -6233,9 +6240,10 @@ additional properties can be passed: |
6233 | 6240 | `crypto.constants.RSA_PSS_SALTLEN_DIGEST` sets the salt length to the digest |
6234 | 6241 | size, `crypto.constants.RSA_PSS_SALTLEN_MAX_SIGN` (default) sets it to the |
6235 | 6242 | maximum permissible value. |
6236 | | -* `context` {ArrayBuffer|Buffer|TypedArray|DataView} For Ed448, ML-DSA, and SLH-DSA, |
6237 | | - this option specifies the optional context to differentiate signatures generated |
6238 | | - for different purposes with the same key. |
| 6243 | +* `context` {ArrayBuffer|Buffer|TypedArray|DataView} For Ed25519[^openssl32] |
| 6244 | + (using Ed25519ctx from [RFC 8032][]), Ed448, ML-DSA, and SLH-DSA, |
| 6245 | + this option specifies the optional context to differentiate signatures |
| 6246 | + generated for different purposes with the same key. |
6239 | 6247 |
|
6240 | 6248 | The `signature` argument is the previously calculated signature for the `data`. |
6241 | 6249 |
|
@@ -6835,6 +6843,7 @@ See the [list of SSL OP Flags][] for details. |
6835 | 6843 | [RFC 5208]: https://www.rfc-editor.org/rfc/rfc5208.txt |
6836 | 6844 | [RFC 5280]: https://www.rfc-editor.org/rfc/rfc5280.txt |
6837 | 6845 | [RFC 7517]: https://www.rfc-editor.org/rfc/rfc7517.txt |
| 6846 | +[RFC 8032]: https://www.rfc-editor.org/rfc/rfc8032.txt |
6838 | 6847 | [Web Crypto API documentation]: webcrypto.md |
6839 | 6848 | [`BN_is_prime_ex`]: https://www.openssl.org/docs/man1.1.1/man3/BN_is_prime_ex.html |
6840 | 6849 | [`Buffer`]: buffer.md |
|