@@ -1181,20 +1181,16 @@ const { createDiffieHellmanGroup } = require('node:crypto'); |
1181 | 1181 | const dh = createDiffieHellmanGroup('modp1'); |
1182 | 1182 | ``` |
1183 | 1183 |
|
1184 | | -The name (e.g. `'modp1'`) is taken from [RFC 2412][] (modp1 and 2) and |
1185 | | -[RFC 3526][]: |
1186 | | - |
1187 | | -```console |
1188 | | -$ perl -ne 'print "$1\n" if /"(modp\d+)"/' src/node_crypto_groups.h |
1189 | | -modp1 # 768 bits |
1190 | | -modp2 # 1024 bits |
1191 | | -modp5 # 1536 bits |
1192 | | -modp14 # 2048 bits |
1193 | | -modp15 # etc. |
1194 | | -modp16 |
1195 | | -modp17 |
1196 | | -modp18 |
1197 | | -``` |
| 1184 | +The following groups are supported: |
| 1185 | + |
| 1186 | +* `'modp1'` (768 bits, [RFC 2409][] Section 6.1) |
| 1187 | +* `'modp2'` (1024 bits, [RFC 2409][] Section 6.2) |
| 1188 | +* `'modp5'` (1536 bits, [RFC 3526][] Section 2) |
| 1189 | +* `'modp14'` (2048 bits, [RFC 3526][] Section 3) |
| 1190 | +* `'modp15'` (3072 bits, [RFC 3526][] Section 4) |
| 1191 | +* `'modp16'` (4096 bits, [RFC 3526][] Section 5) |
| 1192 | +* `'modp17'` (6144 bits, [RFC 3526][] Section 6) |
| 1193 | +* `'modp18'` (8192 bits, [RFC 3526][] Section 7) |
1198 | 1194 |
|
1199 | 1195 | ## Class: `ECDH` |
1200 | 1196 |
|
@@ -6099,6 +6095,7 @@ See the [list of SSL OP Flags][] for details. |
6099 | 6095 | [Nonce-Disrespecting Adversaries]: https://github.com/nonce-disrespect/nonce-disrespect |
6100 | 6096 | [OpenSSL's SPKAC implementation]: https://www.openssl.org/docs/man1.1.0/apps/openssl-spkac.html |
6101 | 6097 | [RFC 1421]: https://www.rfc-editor.org/rfc/rfc1421.txt |
| 6098 | +[RFC 2409]: https://www.rfc-editor.org/rfc/rfc2409.txt |
6102 | 6099 | [RFC 2412]: https://www.rfc-editor.org/rfc/rfc2412.txt |
6103 | 6100 | [RFC 2818]: https://www.rfc-editor.org/rfc/rfc2818.txt |
6104 | 6101 | [RFC 3526]: https://www.rfc-editor.org/rfc/rfc3526.txt |
|