@@ -3597,11 +3597,48 @@ will throw an error in a future version. |
3597 | 3597 |
|
3598 | 3598 | <!-- md-lint skip-deprecation DEP0191 --> |
3599 | 3599 |
|
3600 | | -<!-- md-lint skip-deprecation DEP0192 --> |
| 3600 | +### DEP0192: `require('node:_tls_common')` and `require('node:_tls_wrap')` |
3601 | 3601 |
|
3602 | | -<!-- md-lint skip-deprecation DEP0193 --> |
| 3602 | +<!-- YAML |
| 3603 | +changes: |
| 3604 | + - version: REPLACEME |
| 3605 | + pr-url: https://github.com/nodejs/node/pull/57643 |
| 3606 | + description: Documentation-only deprecation. |
| 3607 | +--> |
| 3608 | + |
| 3609 | +Type: Documentation-only |
| 3610 | + |
| 3611 | +The `node:_tls_common` and `node:_tls_wrap` modules are deprecated as they should be considered |
| 3612 | +an internal nodejs implementation rather than a public facing API, use `node:tls` instead. |
| 3613 | + |
| 3614 | +### DEP0193: `require('node:_stream_*')` |
| 3615 | + |
| 3616 | +<!-- YAML |
| 3617 | +changes: |
| 3618 | + - version: REPLACEME |
| 3619 | + pr-url: https://github.com/nodejs/node/pull/58337 |
| 3620 | + description: Documentation-only deprecation. |
| 3621 | +--> |
| 3622 | + |
| 3623 | +Type: Documentation-only |
| 3624 | + |
| 3625 | +The `node:_stream_duplex`, `node:_stream_passthrough`, `node:_stream_readable`, `node:_stream_transform`, |
| 3626 | +`node:_stream_wrap` and `node:_stream_writable` modules are deprecated as they should be considered |
| 3627 | +an internal nodejs implementation rather than a public facing API, use `node:stream` instead. |
| 3628 | + |
| 3629 | +### DEP0194: `require('node:http2').Http2Stream.priority` |
| 3630 | + |
| 3631 | +<!-- YAML |
| 3632 | +changes: |
| 3633 | + - version: REPLACEME |
| 3634 | + pr-url: https://github.com/nodejs/node/pull/58313 |
| 3635 | + description: Documentation-only deprecation. |
| 3636 | +--> |
| 3637 | + |
| 3638 | +Type: Documentation-only |
3603 | 3639 |
|
3604 | | -<!-- md-lint skip-deprecation DEP0194 --> |
| 3640 | +The support for priority signaling has been deprecated in the [RFC 9113][], and |
| 3641 | +will be removed in future versions of Node.js. |
3605 | 3642 |
|
3606 | 3643 | <!-- md-lint skip-deprecation DEP0195 --> |
3607 | 3644 |
|
@@ -3625,6 +3662,7 @@ Creating SHAKE-128 and SHAKE-256 digests without an explicit `options.outputLeng |
3625 | 3662 | [NIST SP 800-38D]: https://nvlpubs.nist.gov/nistpubs/Legacy/SP/nistspecialpublication800-38d.pdf |
3626 | 3663 | [RFC 6066]: https://tools.ietf.org/html/rfc6066#section-3 |
3627 | 3664 | [RFC 8247 Section 2.4]: https://www.rfc-editor.org/rfc/rfc8247#section-2.4 |
| 3665 | +[RFC 9113]: https://datatracker.ietf.org/doc/html/rfc9113#section-5.3.1 |
3628 | 3666 | [WHATWG URL API]: url.md#the-whatwg-url-api |
3629 | 3667 | [`"exports"` or `"main"` entry]: packages.md#main-entry-point-export |
3630 | 3668 | [`'uncaughtException'`]: process.md#event-uncaughtexception |
|