GV

GeezerVison

The World Wide Web, restored to 800 pixels of glory.

Home|About|Gaming cabinet|Archives|How it works|Starter sites

On this site

  • Sign in
  • ActionsCI/CD and automation
  • CodespacesCloud development environments
  • All Features
  • Documentation
  • Training
  • Certifications
  • Build with Copilot
  • Customize Copilot
  • Integrations
  • Trending repos
  • GitHub Sponsors
  • Developer articles
  • Enterprises

This view

  • Original page
  • New address

GeezerVison is showing github.com — GitHub - openssl/openssl: General purpose TLS and crypto library

BranchesTags
Open more actions menu

Latest commit

 

History

41,651 Commits
41,651 Commits

Folders and files

NameName
Last commit message
Last commit date
.ctags.d
.ctags.d
 
 
.github
.github
 
 
Configurations
Configurations
 
 
VMS
VMS
 
 
apps
apps
 
 
cloudflare-quiche @ 7ab6a55
cloudflare-quiche @ 7ab6a55
 
 
crypto
crypto
 
 
demos
demos
 
 
dev
dev
 
 
doc
doc
 
 
exporters
exporters
 
 
external/perl
external/perl
 
 
fuzz
fuzz
 
 
gost-engine @ 74b1f4f
gost-engine @ 74b1f4f
 
 
include
include
 
 
krb5 @ 784c38f
krb5 @ 784c38f
 
 
ms
ms
 
 
oqs-provider @ c5fb439
oqs-provider @ c5fb439
 
 
os-dep
os-dep
 
 
pkcs11-provider @ b55b943
pkcs11-provider @ b55b943
 
 
providers
providers
 
 
pyca-cryptography @ e83bbe5
pyca-cryptography @ e83bbe5
 
 
python-ecdsa @ 4096fa0
python-ecdsa @ 4096fa0
 
 
ssl
ssl
 
 
test
test
 
 
tlsfuzzer @ 61f45d9
tlsfuzzer @ 61f45d9
 
 
tlslite-ng @ 77ef321
tlslite-ng @ 77ef321
 
 
util
util
 
 
wycheproof @ 3fa63dd
wycheproof @ 3fa63dd
 
 
.clang-format
.clang-format
 
 
.codespellrc
.codespellrc
 
 
.git-blame-ignore-revs
.git-blame-ignore-revs
 
 
.gitattributes
.gitattributes
 
 
.gitignore
.gitignore
 
 
.gitmodules
.gitmodules
 
 
.pre-commit-config.yaml
.pre-commit-config.yaml
 
 
ACKNOWLEDGEMENTS.md
ACKNOWLEDGEMENTS.md
 
 
AUTHORS.md
AUTHORS.md
 
 
CHANGES.md
CHANGES.md
 
 
CODE-OF-CONDUCT.md
CODE-OF-CONDUCT.md
 
 
CONTRIBUTING.md
CONTRIBUTING.md
 
 
Configure
Configure
 
 
DOCUMENTATION.md
DOCUMENTATION.md
 
 
HOWTO.md
HOWTO.md
 
 
INSTALL.md
INSTALL.md
 
 
LICENSE.txt
LICENSE.txt
 
 
NEWS.md
NEWS.md
 
 
NOTES-ANDROID.md
NOTES-ANDROID.md
 
 
NOTES-C99.md
NOTES-C99.md
 
 
NOTES-DJGPP.md
NOTES-DJGPP.md
 
 
NOTES-NONSTOP.md
NOTES-NONSTOP.md
 
 
NOTES-PERL.md
NOTES-PERL.md
 
 
NOTES-POSIX.md
NOTES-POSIX.md
 
 
NOTES-SANITIZERS.md
NOTES-SANITIZERS.md
 
 
NOTES-UNIX.md
NOTES-UNIX.md
 
 
NOTES-VALGRIND.md
NOTES-VALGRIND.md
 
 
NOTES-VMS.md
NOTES-VMS.md
 
 
NOTES-WINDOWS.md
NOTES-WINDOWS.md
 
 
README-FIPS.md
README-FIPS.md
 
 
README-PROVIDERS.md
README-PROVIDERS.md
 
 
README-QUIC.md
README-QUIC.md
 
 
README.md
README.md
 
 
REVIEW.md
REVIEW.md
 
 
STYLE.md
STYLE.md
 
 
SUPPORT.md
SUPPORT.md
 
 
VERSION.dat
VERSION.dat
 
 
build.info
build.info
 
 
config
config
 
 
config.com
config.com
 
 
configdata.pm.in
configdata.pm.in
 
 
funding.json
funding.json
 
 

Repository files navigation

Welcome to the OpenSSL Project

openssl logo

github actions ci badge Nightly OS Zoo ci badge Provider Compatibility Quic Interop Daily checks LFX Health Score

OpenSSL is a robust, commercial-grade, full-featured Open Source Toolkit for the Transport Layer Security (TLS, formerly SSL), Datagram TLS (DTLS), and QUIC protocols.

The protocol implementations are based on a full-strength general purpose cryptographic library, which can also be used stand-alone. Also included is a cryptographic module validated to conform with FIPS standards.

OpenSSL is descended from the SSLeay library developed by Eric A. Young and Tim J. Hudson.

The official Home Page of the OpenSSL Project is www.openssl.org.

Table of Contents

  • Overview
  • Download
  • Build and Install
  • Documentation
  • License
  • Support
  • Contributing
  • Legalities

Overview

The OpenSSL toolkit includes:

  • libssl an implementation of all TLS protocol versions up to TLSv1.3 (RFC 8446), DTLS protocol versions up to DTLSv1.3 (RFC 9147) and the QUIC version 1 protocol (RFC 9000).

  • libcrypto a full-strength general purpose cryptographic library. It constitutes the basis of the TLS implementation, but can also be used independently.

  • openssl the OpenSSL command line tool, a Swiss Army knife for cryptographic tasks, testing and analyzing. It can be used for

    • creation of key parameters
    • creation of X.509 certificates, CSRs and CRLs
    • calculation of message digests
    • encryption and decryption
    • SSL/TLS/DTLS and client and server tests
    • QUIC client tests
    • handling of S/MIME signed or encrypted mail
    • and more...

Download

For Production Use

Source code tarballs of the official releases can be downloaded from openssl-library.org/source/. The OpenSSL project does not distribute the toolkit in binary form.

However, for a large variety of operating systems precompiled versions of the OpenSSL toolkit are available. In particular, on Linux and other Unix operating systems, it is normally recommended to link against the precompiled shared libraries provided by the distributor or vendor.

We also maintain a list of third parties that produce OpenSSL binaries for various Operating Systems (including Windows) on the Binaries page on our wiki.

For Testing and Development

Although testing and development could in theory also be done using the source tarballs, having a local copy of the git repository with the entire project history gives you much more insight into the code base.

The main OpenSSL Git repository is private. There is a public GitHub mirror of it at github.com/openssl/openssl, which is updated automatically from the former on every commit.

A local copy of the Git repository can be obtained by cloning it from the GitHub mirror using

git clone https://github.com/openssl/openssl.git

If you intend to contribute to OpenSSL, either to fix bugs or contribute new features, you need to fork the GitHub mirror and clone your public fork instead.

git clone https://github.com/yourname/openssl.git

This is necessary because all development of OpenSSL nowadays is done via GitHub pull requests. For more details, see Contributing.

Build and Install

After obtaining the Source, have a look at the INSTALL file for detailed instructions about building and installing OpenSSL. For some platforms, the installation instructions are amended by a platform specific document.

  • Notes for UNIX-like platforms
  • Notes for Android platforms
  • Notes for Windows platforms
  • Notes for the DOS platform with DJGPP
  • Notes for the OpenVMS platform
  • Notes on Perl
  • Notes on Valgrind

Specific notes on upgrading to OpenSSL 3.x from previous versions can be found in the ossl-guide-migration(7ossl) manual page.

Documentation

README Files

There are some README.md files in the top level of the source distribution containing additional information on specific topics.

  • Information about the OpenSSL QUIC protocol implementation
  • Information about the OpenSSL Provider architecture
  • Information about using the OpenSSL FIPS validated module

The OpenSSL Guide

There are some tutorial and introductory pages on some important OpenSSL topics within the OpenSSL Guide.

Manual Pages

The manual pages for the master branch and all current stable releases are available online.

  • OpenSSL master
  • OpenSSL 4.1
  • OpenSSL 4.0
  • OpenSSL 3.6
  • OpenSSL 3.5

Demos

There are numerous source code demos for using various OpenSSL capabilities in the demos subfolder.

Wiki

There is a GitHub Wiki which is currently not very active.

License

OpenSSL is licensed under the Apache License 2.0, which means that you are free to get and use it for commercial and non-commercial purposes as long as you fulfill its conditions.

See the LICENSE.txt file for more details.

Support

There are various ways to get in touch. The correct channel depends on your requirement. See the SUPPORT file for more details.

Contributing

If you are interested and willing to contribute to the OpenSSL project, please take a look at the CONTRIBUTING file.

Legalities

A number of nations restrict the use or export of cryptography. If you are potentially subject to such restrictions, you should seek legal advice before attempting to develop or distribute cryptographic code.

Copyright

Copyright (c) 1998-2026 The OpenSSL Project Authors

Copyright (c) 1995-1998 Eric A. Young, Tim J. Hudson

All rights reserved.

About

General purpose TLS and crypto library

openssl-library.org/

Topics

cryptographydecryptionencryptionopensslssltls

Resources

Readme
Apache-2.0 license

Code of conduct

Code of conduct

Contributing

Contributing

Security policy

Security policy
Activity
Custom properties

Stars

31.4k stars

Watchers

1.0k watching

Forks

11.6k forks
Report repository

Releases

Sponsor this project

Used by

Contributors

Languages

You are visitor 01402503 — GeezerVison does not store the pages you look up.
Best viewed with Netscape Navigator 4.7 or Internet Explorer 6 at 800×600. No cookies required.