GeezerVisonThe World Wide Web, restored to 800 pixels of glory. | ||||||||||
| Home|About|Gaming cabinet|Archives|How it works|Starter sites | ||||||||||
GeezerVison is showing howdoesinternetwork.com — MIME – Multipurpose Internet Mail Extensions Internet standard MIME is able to extend the e-mail format for the purpose to support the following things as text, non-text attachment, a message organization with manifold parts and non-ASCII header information. The existence of MIME protocol has become very important because SMTP as basic e-mail transmission protocol can support only 7-bit of ASCII characters set. But MIME as Presentation layer protocol can hold up 8-bit binary content by describing the ways of sending certain types of data via an electronic mail. But data types are including that text other than English language too, files with images, sounds, or movies, etc. MIME also specified about the set of e-mail’s headers to facilitate a message additional attributes specification, which may include content type, and description of transfer encoding set. MIME is as well specified the set of laws and non-ASCII character’s encoding in the message headers of e-mail. But when RFC 822-style header’s practice is being made for the attributes of MIME message then without making any change to on hand email servers, plain texted e-mails are permitted to play their role in both directions with reachable clients. But all this is possible when MIME headers are declared optional. Anyway, following RFCs are mentioned here for your better understanding regarding the subject. RFC 1426 is dealt with 8bit MIME transportation. But RFC 1847 specifies the MIME security multiparts while RFC 3156 describes MIME security by means of OpenPGP. Similarly, RFC 2183 is dealt with the information regarding communicating presentation in e-mail messages. RFC 2387 is related with MIME multipart or related content-type but RFC 1521 covers that mechanism specifies the Internet Messaging Bodies format. Extensible MIME definition is included a scheme to schedule fresh contents types and attribute values of MIME. Typical Header fields of MIMEHeader’s typical fields are as under:
Content-Type: type/subtype;parameter
MIME encodings is performed in the form of base64 and quoted-printable encoding according to RFC 1521. In case of base64, the actual data is divided into 3 octets groups but quoted-printable encoding is suitable for the data included printable characters as 33-60 characters range and 62-126 characters range. | ||||||||||
| You are visitor 01402503 — GeezerVison does not store the pages you look up. Best viewed with Netscape Navigator 4.7 or Internet Explorer 6 at 800×600. No cookies required. |