GV

GeezerVison

The World Wide Web, restored to 800 pixels of glory.

Home|About|Gaming cabinet|Archives|How it works|Starter sites

On this site

  • Pagina principale
  • Ultime modifiche
  • Una voce a caso
  • Nelle vicinanze
  • Vetrina
  • Aiuto
  • Sportello informazioni
  • Pagine speciali
  • Portale Comunità
  • Bar
  • Il Wikipediano
  • Contatti
  • Ricerca
  • Fai una donazione

This view

  • Original page
  • New address

GeezerVison is showing it.wikipedia.org — Internet Control Message Protocol - Wikipedia

In telecomunicazioni e informatica l'Internet Control Message Protocol (ICMP) è un protocollo di servizio per reti a pacchetto che si occupa di trasmettere informazioni riguardanti malfunzionamenti, informazioni di controllo o messaggi tra i vari componenti di una rete di calcolatori.

Descrizione

ICMP è incapsulato direttamente in IP (è un protocollo di livello 3 dello stack TCP/IP) e non è quindi garantita la consegna a destinazione dei pacchetti. Viene utilizzato da molti applicativi di rete, tra cui ping e traceroute.

È definito nelle seguenti RFC:

  • RFC 0792: Internet Control Message Protocol - settembre 1981
  • RFC 1349: Type of Service in the Internet Protocol Suite - luglio 1992
  • RFC 1788: ICMP Domain Name Messages - aprile 1995
  • RFC 2463: Internet Control Message Protocol (ICMPv6) for the Internet Protocol Version 6 (IPv6) Specification - dicembre 1998
  • RFC 2521: ICMP Security Failures Messages - marzo 1999

Incapsulamento

Un messaggio ICMP viene incapsulato in IP:

  +------------+-----------+-------------+----------
  | Header L2  | Header IP | Header ICMP | Dati....
  +------------+-----------+-------------+----------

Header ICMP

ICMP può essere usato per veicolare diversi tipi di messaggi di gestione, identificati primariamente dal tipo e dal relativo codice.

bit del messaggio:

   0                   1                   2                   3
   0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
  +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
  |     Tipo      |    Codice     |  Checksum dell'Header ICMP    |
  +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
  |     Dati....
  +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

Tipo

Byte (8 bit), specifica il formato del messaggio ICMP:

  • 0 Echo reply
  • 1 Non assegnato
  • 2 Non assegnato
  • 3 Destinazione irraggiungibile
  • 4 Source quench
  • 5 Redirect
  • 6 Indirizzo host alternativo
  • 7 Non assegnato
  • 8 Echo request
  • 9 Router advertisement
  • 10 Router selection
  • 11 Time to Live scaduto
  • 12 Errore nei parametri
  • 13 Timestamp request
  • 14 Timestamp reply
  • 15 Information Request
  • 16 Information Reply
  • 17 Richiesta address mask
  • 18 Risposta address mask
  • 19 Riservato (per sicurezza)
  • 20-29 Riservati (per test di robustezza)
  • 30 Traceroute
  • 31 Errore di conversione datagramma
  • 32 Redirect su host mobile
  • 33 IPv6 Where-Are-You
  • 34 IPv6 I-Am-Here
  • 35 Mobile Registration Request
  • 36 Mobile Registration Reply
  • 37 Domain Name request
  • 38 Domain Name reply
  • 39-255 Non assegnati

Codice

Byte (8 bit), ulteriore qualificazione del messaggio

Checksum dell'Header ICMP

Word (16 bit), controllo della correttezza del messaggio.

È il complemento a uno, troncato a 16 bit, del complemento a uno della somma dei primi bit del messaggio con il campo "Tipo".

Dati

Lunghezza variabile, sono i dati specifici del tipo di messaggio identificato dai campi "Tipo" e "Codice"

Bibliografia

  • (EN) RFC 792 — Internet Control Message Protocol, su datatracker.ietf.org, Internet Engineering Task Force.
  • (EN) RFC 1122 — Requirements for Internet Hosts -- Communication Layers, su datatracker.ietf.org, Internet Engineering Task Force.
  • (EN) RFC 1700 — Assigned Numbers, su datatracker.ietf.org, Internet Engineering Task Force.
  • (EN) RFC 1716 — Towards Requirements for IP Routers, su datatracker.ietf.org, Internet Engineering Task Force.

Voci correlate

  • Internet
  • TCP/IP
  • ICMPv6

Altri progetti

Altri progetti

  • Wikibooks
  • Wikimedia Commons
  • Collabora a Wikibooks Wikibooks contiene testi o manuali sull'Internet Control Message Protocol
  • Collabora a Wikimedia Commons Wikimedia Commons contiene immagini o altri file sull'Internet Control Message Protocol

Collegamenti esterni

  • (EN) Denis Howe, Internet Control Message Protocol, in Free On-line Dictionary of Computing. Disponibile con licenza GFDL
  • (EN) Internet Control Message Protocol (ICMP) Parameters, su IANA, 25 settembre 2020. URL consultato il 9 febbraio 2024.
  • (EN) What is the Internet Control Message Protocol (ICMP)?, su Cloudflare. URL consultato il 9 febbraio 2024.
  • (EN) ICMP Sequence Diagram (PDF), su eventhelix.com. URL consultato il 19 settembre 2008 (archiviato dall'url originale il 6 novembre 2020).
Controllo di autoritàGND (DE) 4585818-4
Estratto da "https://it.wikipedia.org/w/index.php?title=Internet_Control_Message_Protocol&oldid=143908459"
Categorie:
  • Protocolli di Internet
  • Protocolli livello rete
Categorie nascoste:
  • Voci con codice GND
  • Voci non biografiche con codici di controllo di autorità
  • Pagine che utilizzano collegamenti magici RFC
You are visitor 01402503 — GeezerVison does not store the pages you look up.
Best viewed with Netscape Navigator 4.7 or Internet Explorer 6 at 800×600. No cookies required.