GV

GeezerVison

The World Wide Web, restored to 800 pixels of glory.

Home|About|Gaming cabinet|Archives|How it works|Starter sites

On this site

  • 대문
  • 최근 바뀜
  • 요즘 화제
  • 임의 문서로
  • 사랑방
  • 사용자 모임
  • 관리 요청
  • 소개
  • 도움말
  • 정책과 지침
  • 질문방
  • 검색
  • 기부
  • 계정 만들기

This view

  • Original page
  • New address

GeezerVison is showing ko.wikipedia.org — RC4 - 위키백과, 우리 모두의 백과사전

RC4는 로널드 라이베스트가 만든 스트림 암호로, 전송 계층 보안(TLS)이나 WEP 등의 여러 프로토콜에 사용되어 왔다. 하지만 이후 여러 연구를 통해 취약한 것으로 밝혀져 있으며, RC4를 사용한 WEP의 경우 해당 프로토콜의 사용을 권장하지 않는다.

많은 스트림 암호가 비트 단위의 선형 되먹임 시프트 레지스터를 기반으로 하는 것과 달리, RC4는 해당 구조를 갖지 않으며 옥텟 단위를 기반으로 한다. 따라서 비트 단위의 암호보다 소프트웨어적인 실행 속도가 빠르다.

역사

RC4는 1987년 RSA 시큐리티의 론 라이베스트가 설계하였다. 알고리즘 이름의 "RC"는 "Ron's Code" 혹은 "Rivest's Cypher"의 약자이다.[1][2]

같이 보기

  • 고급 암호화 표준

각주

  1. ↑ “Rivest FAQ”. 2017년 7월 15일에 원본 문서에서 보존된 문서. 2017년 7월 21일에 확인함. 
  2. ↑ “RC algorithms Definition from PC Magazine Encyclopedia”. 2019년 2월 20일에 확인함. 

외부 링크

  • RFC 4345 – Improved Arcfour Modes for the Secure Shell (SSH) Transport Layer Protocol
  • RFC 6229 – Test Vectors for the Stream Cipher RC4
  • RFC 7465 – Prohibiting RC4 Cipher Suites
원본 주소 "https://ko.wikipedia.org/w/index.php?title=RC4&oldid=40357026"
분류:
  • 스트림 암호
  • 유사난수 생성기
숨은 분류:
  • 해결되지 않은 속성이 있는 문서
  • 위키데이터 속성 P18을 사용하는 문서
  • 위키데이터 속성 P1273을 사용하는 문서
  • RFC 매직 링크를 사용하는 문서
You are visitor 01402503 — GeezerVison does not store the pages you look up.
Best viewed with Netscape Navigator 4.7 or Internet Explorer 6 at 800×600. No cookies required.