GeezerVisonThe World Wide Web, restored to 800 pixels of glory. |
| Home|About|Gaming cabinet|Archives|How it works|Starter sites |
GeezerVison is showing www.isc.org — IETF Standards Written by ISC Contributors IETF Standards Written by ISC ContributorsWe have years of experience helping to keep the Internet running ISC has a long history of contributing to, and implementing, open community standards.The documents that specify and discuss current and developing standards for the Internet are called Requests for Comments, or RFCs. That name belies their role, as an RFC that has been assigned the status “standard” is the primary specification of an Internet standard. Other status codes include “draft standard,” “informational,” “historic,” “proposed standard,” or “experimental.” Many of the early RFC documents have status “unknown” because they come from the long-gone era when an RFC really was just a request for comments. The Internet Engineering Task Force (IETF) has ultimate responsibility for RFC documents, and maintains a complete list of them in their online RFC Directory. RFCs authored or co-authored by ISC affiliatesISC staff members and affiliates have written or contributed more than 100 RFCs, listed below. RFCs pertaining to DNSThe Domain Name System protocols are more than 20 years old. Many of the older RFCs are obsolete, but there are still clients running software implementing the very oldest protocols. In addition to the RFCs authored or co-authored by ISC contributors, you may find it interesting and/or useful to review all the IETF RFCs related to DNS, currently maintained by PowerDNS. FAQS.org also maintains a list of DNS Protocol Related Documents. RFCs pertaining to DHCPBecause DHCP operates at several levels in the network and operating system stacks, the RFCs that pertain to it include some that do not even mention it. ISC has prepared a collection of DHCP references, which is included in every ISC DHCP distribution as doc/References.html. One or more of the authors of each of these RFCs is or was affiliated with ISC in some capacity (e.g. staff member, consultant, director): RFC1036 Standard for Interchange of USENET Messages RFC1486 An Experiment in Remote Printing RFC1528 Principles of Operation for the TPC.INT Subdomain: Remote Printing – Technical Procedures RFC1529 Principles of Operation for the TPC.INT Subdomain: Remote Printing – Administrative Policies RFC1530 Principles of Operation for the TPC.INT Subdomain: General Principles and Policy RFC1611 DNS Server MIB Extensions RFC1612 DNS Resolver MIB Extensions RFC1846 SMTP 521 Reply Code RFC1876 A Means for Expressing Location Information in the Domain Name System RFC1996 A Mechanism for Prompt Notification of Zone Changes (DNS NOTIFY) RFC2010 Operational Criteria for Root Name Servers RFC2052 A DNS RR for specifying the location of services (DNS SRV) RFC2129 Toshiba’s Flow Attribute Notification Protocol (FANP) Specification RFC2136 Dynamic Updates in the Domain Name System (DNS UPDATE) RFC2186 Internet Cache Protocol (ICP), version 2 RFC2187 Application of Internet Cache Protocol (ICP), version 2 RFC2308 Negative Caching of DNS Queries (DNS NCACHE) RFC2317 Classless IN-ADDR.ARPA delegation RFC2545 Use of BGP-4 Multiprotocol Extensions for IPv6 Inter-Domain Routing RFC2576 Coexistence between Version 1, Version 2, and Version 3 of the Internet-standard Network Management Framework RFC2655 CIP Index Object Format for SOIF Objects RFC2671 Extension Mechanisms for DNS (EDNS0) RFC2756 Hyper Text Caching Protocol (HTCP/0.0) RFC2782 A DNS RR for specifying the location of services (DNS SRV) RFC2845 Secret Key Transaction Authentication for DNS (TSIG) RFC2851 Textual Conventions for Internet Network Addresses RFC3197 Applicability Statement for DNS MIB Extensions RFC3291 Textual Conventions for Internet Network Addresses RFC3364 Tradeoffs in Domain Name System (DNS) Support for Internet Protocol version 6 (IPv6) RFC3542 Advanced Sockets Application Program Interface (API) for IPv6 RFC3582 Goals for IPv6 Site-Multihoming Architectures RFC3584 Coexistence between Version 1, Version 2, and Version 3 of the Internet-standard Network Management Framework RFC3724 The Rise of the Middle and the Future of End-to-End: Reflections on the Evolution of the Internet Architecture RFC3750 Unmanaged Networks IPv6 Transition Scenarios RFC3776 Using IPsec to Protect Mobile IPv6 Signaling Between Mobile Nodes and Home Agents RFC3833 Threat Analysis of the Domain Name System (DNS) RFC3865 A No Soliciting Simple Mail Transfer Protocol (SMTP) Service Extension RFC3904 Evaluation of IPv6 Transition Mechanisms for Unmanaged Networks RFC4001 Textual Conventions for Internet Network Addresses RFC4007 IPv6 Scoped Address Architecture RFC4012 Routing Policy Specification Language next generation (RPSLng) RFC4033 DNS Security Introduction and Requirements RFC4034 Resource Records for the DNS Security Extensions RFC4035 Protocol Modifications for the DNS Security Extensions RFC4071 Structure of the IETF Administrative Support Activity (IASA) RFC4074 Common Misbehavior Against DNS Queries for IPv6 Addresses RFC4095 Attaching Meaning to Solicitation Class Keywords RFC4096 Policy-Mandated Labels Such as “Adv:” in Email Subject Headers Considered Ineffective At Best RFC4116 IPv4 Multihoming Practices and Limitations RFC4286 Multicast Router Discovery RFC4293 Management Information Base for the Internet Protocol (IP) RFC4431 The DNSSEC Lookaside Validation (DLV) DNS Resource Record RFC4786 Operation of Anycast Services RFC4843 An IPv6 Prefix for Overlay Routable Cryptographic Hash Identifiers (ORCHID) RFC4862 IPv6 Stateless Address Autoconfiguration RFC4877 Mobile IPv6 Operation with IKEv2 and the Revised IPsec Architecture RFC4892 Requirements for a Mechanism Identifying a Name Server Instance RFC5001 DNS Name Server Identifier (NSID) Option RFC5071 Dynamic Host Configuration Protocol Options Used by PXELINUX RFC5095 Deprecation of Type 0 Routing Headers in IPv6 RFC5186 IGMPv3/MLDv2 and Multicast Routing Protocol Interaction RFC5358 Preventing Use of Recursive Nameservers in Reflector Attacks RFC5507 Design Choices When Expanding the DNS RFC5625 DNS Proxy Implementation Guidelines RFC5905 Network Time Protocol Version 4 RFC5966 DNS Transport over TCP - Implementation Requirements RFC6276 DHCPv6 Prefix Delegation for Network Mobility RFC6303 Locally Served DNS Zones RFC6334 Dynamic Host Configuration Protocol for IPv6 (DHCPv6) Option for Dual-Stack Lite RFC6486 Manifests for the Resource Public Key Infrastructure (RPKI) RFC6492 A Protocol for Provisioning Resource Certificates RFC6594 Use of the SHA-256 Algorithm with RSA,
Digital Signature Algorithm (DSA), and Elliptic Curve DSA (ECDSA) in SSHFP Resource Records RFC6781 DNSSEC Operational Practices, Version 2 RFC6887 Port Control Protocol RFC6853 DHCPv6 Redundancy Deployment Considerations RFC6887 Port Control Protocol (PCP) RFC6891 Extension Mechanisms for DNS (EDNS(0)) RFC6915 Flow Identity Extension for HTTP-Enabled Location Delivery (HELD) RFC7031 DHCPv6 Failover Requirements RFC7216 Location Information Server (LIS) Discovery RFC7227 Guidelines for Creating New DHCPv6 Options RFC7314 Extension Mechanisms for DNS (EDNS) EXPIRE Option RFC7341 DHCPv4-over-DHCPv6 (DHCP 4o6) Transport RFC7343 An IPv6 Prefix for Overlay Routable Cryptographic Hash Identifiers Version 2 (ORCHIDv2) RFC7550 Issues and Recommendations with Multiple Stateful DHCPv6 Options RFC7583 DNSSEC Key Rollover Timing Considerations RFC7598 DHCPv6 Options for Configuration of Softwire Address and Port-Mapped Clients RFC7766 DNS Transport over TCP - Implementation Requirements RFC7793 Adding 100.64.0.0/10 Prefixes to the IPv4 Locally-Served DNS Zones Registry RFC7819 Privacy Considerations for DHCP RFC7824 Privacy Considerations for DHCPv6 RFC7828 The edns-tcp-keepalive EDNS0 Option RFC7844 Anonymity Profiles for DHCP Clients RFC7873 Domain Name System (DNS) Cookies RFC7969 Customizing DHCP Configuration on the Basis of Network Topology RFC8080 Edwards-Curve Digital Security Algorithm (EdDSA) for DNSSEC RFC8156 DHCPv6 Failover Protocol RFC8415 Dynamic Host Configuration Protocol for IPv6 (DHCPv6) RFC8482 Providing Minimal-Sized Responses to DNS Queries That Have QTYPE=ANY RFC8490 DNS Stateful Operations RFC8624 Algorithm Implementation Requirements and Usage Guidance for DNSSEC RFC8749 Moving DNSSEC Lookaside Validation (DLV) to Historic Status RFC8906 A Common Operational Problem in DNS Servers: Failure to Communicate RFC8914 Extended DNS Errors RFC8925 IPv6-Only Preferred Option for DHCPv4 RFC8945 Secret Key Transaction Authentication for DNS (TSIG) RFC8947 Link-Layer Address Assignment Mechanism for DHCPv6 RFC9018 Interoperable Domain Name System (DNS) Server Cookies RFC9108 YANG Types for DNS Classes and Resource Record Types RFC9432 DNS Catalog Zones RFC9471 DNS Glue Requirements in Referral Responses RFC9527 DHCPv6 Options for the Homenet Naming Authority RFC9619 In the DNS, QDCOUNT Is (Usually) One RFC9915 Dynamic Host Configuration Protocol for IPv6 (DHCPv6) RFC10029 DNS Multiple QTYPEs |
| You are visitor 01402503 — GeezerVison does not store the pages you look up. Best viewed with Netscape Navigator 4.7 or Internet Explorer 6 at 800×600. No cookies required. |