GeezerVisonThe World Wide Web, restored to 800 pixels of glory. | ||||||||||||||||||||
| Home|About|Gaming cabinet|Archives|How it works|Starter sites | ||||||||||||||||||||
GeezerVison is showing datatracker.ietf.org — RFC 1183: New DNS RR Definitions Network Working Group C. Everhart Request for Comments: 1183 Transarc Updates: RFCs 1034, 1035 L. Mamakos University of Maryland R. Ullmann Prime Computer P. Mockapetris, Editor ISI October 1990 RFC 1183 New DNS RR Definitions October 1990 RFC 1183 New DNS RR Definitions October 1990 machines: bigbird.toaster.com, ernie.toaster.com, and henson.toaster.com. These three machines would be listed in three AFSDB RRs. These might appear in a master file as: toaster.com. AFSDB 1 bigbird.toaster.com. toaster.com. AFSDB 1 ernie.toaster.com. toaster.com. AFSDB 1 henson.toaster.com. As another example use of this RR, suppose that Femto College (domain name femto.edu) has deployed DCE, and that their DCE cell root directory is served by processes running on green.femto.edu and turquoise.femto.edu. Furthermore, their DCE file servers also run AFS 3.0-compatible volume location servers, on the hosts turquoise.femto.edu and orange.femto.edu. These machines would be listed in four AFSDB RRs, which might appear in a master file as: femto.edu. AFSDB 2 green.femto.edu. femto.edu. AFSDB 2 turquoise.femto.edu. femto.edu. AFSDB 1 turquoise.femto.edu. femto.edu. AFSDB 1 orange.femto.edu. RFC 1183 New DNS RR Definitions October 1990 The POSTMASTER mailbox on that host continues to be a good contact point for mail problems, and the zone contact in the SOA record for database problem, but the RP record allows us to associate a mailbox to entities that don't receive mail or are not directly connected (namespace-wise) to the problem (e.g., GATEWAY.ISI.EDU might want to point at [email protected], and GATEWAY doesn't get mail, nor does the ISI zone administrator have a clue about fixing gateways). RFC 1183 New DNS RR Definitions October 1990 EXAMPLES Some examples of how the RP record might be used. sayshell.umd.edu. A 128.8.1.14 MX 10 sayshell.umd.edu. HINFO NeXT UNIX WKS 128.8.1.14 tcp ftp telnet smtp RP louie.trantor.umd.edu. LAM1.people.umd.edu. LAM1.people.umd.edu. TXT ( "Louis A. Mamakos, (301) 454-2946, don't call me at home!" ) In this example, the responsible person's mailbox for the host SAYSHELL.UMD.EDU is [email protected]. The TXT RR at LAM1.people.umd.edu provides additional information and advice. TERP.UMD.EDU. A 128.8.10.90 MX 10 128.8.10.90 HINFO MICROVAX-II UNIX WKS 128.8.10.90 udp domain WKS 128.8.10.90 tcp ftp telnet smtp domain RP louie.trantor.umd.edu. LAM1.people.umd.edu. RP root.terp.umd.edu. ops.CS.UMD.EDU. TRANTOR.UMD.EDU. A 128.8.10.14 MX 10 trantor.umd.edu. HINFO MICROVAX-II UNIX WKS 128.8.10.14 udp domain WKS 128.8.10.14 tcp ftp telnet smtp domain RP louie.trantor.umd.edu. LAM1.people.umd.edu. RP petry.netwolf.umd.edu. petry.people.UMD.EDU. RP root.trantor.umd.edu. ops.CS.UMD.EDU. RP gregh.sunset.umd.edu. . LAM1.people.umd.edu. TXT "Louis A. Mamakos (301) 454-2946" petry.people.umd.edu. TXT "Michael G. Petry (301) 454-2946" ops.CS.UMD.EDU. TXT "CS Operations Staff (301) 454-2943" This set of resource records has two hosts, TRANTOR.UMD.EDU and TERP.UMD.EDU, as well as a number of TXT RRs. Note that TERP.UMD.EDU and TRANTOR.UMD.EDU both reference the same pair of TXT resource records, although the mail box names (root.terp.umd.edu and root.trantor.umd.edu) differ. Here, we obviously care much more if the machine flakes out, as we've specified four persons which might want to be notified of problems or other events involving TRANTOR.UMD.EDU. In this example, the last RP Everhart, Mamakos, Ullmann & Mockapetris [Page 5] RFC 1183 New DNS RR Definitions October 1990 RR for TRANTOR.UMD.EDU specifies a mailbox (gregh.sunset.umd.edu), but no associated TXT RR. RFC 1183 New DNS RR Definitions October 1990 The format of X25 is class insensitive. X25 RRs cause no additional section processing. The <PSDN-address> is a string of decimal digits, beginning with the 4 digit DNIC (Data Network Identification Code), as specified in X.121. National prefixes (such as a 0) MUST NOT be used. For example: Relay.Prime.COM. X25 311061700956 RFC 1183 New DNS RR Definitions October 1990 general case. The <sa> is a string of hexadecimal digits. For digits 0-9, the concrete encoding in the Q.931 call setup information element is identical to BCD. For example: Relay.Prime.COM. IN ISDN 150862028003217 sh.Prime.COM. IN ISDN 150862028003217 004 (Note: "1" is the country code for the North American Integrated Numbering Area, i.e., the system of "area codes" familiar to people in those countries.) The RR data is the ASCII representation of the digits. It is encoded as one or two <character-string>s, i.e., count followed by characters. CCITT recommendation E.166 [9] defines prefix escape codes for the representation of ISDN (E.163/E.164) addresses in X.121, and PSDN (X.121) addresses in E.164. It specifies that the exact codes are a "national matter", i.e., different on different networks. A host connected to the ISDN may be able to use both the X25 and ISDN addresses, with the local prefix added. RFC 1183 New DNS RR Definitions October 1990 least one A, X25, or ISDN record. The format of the RT RR is class insensitive. RT records cause type X25, ISDN, and A additional section processing for <intermediate- host>. For example, sh.prime.com. IN RT 2 Relay.Prime.COM. IN RT 10 NET.Prime.COM. *.prime.com. IN RT 90 Relay.Prime.COM. When a host is looking up DNS records to attempt to route a datagram, it first looks for RT records for the destination host, which point to hosts with address records (A, X25, ISDN) compatible with the wide area networks available to the host. If it is itself in the set of RT records, it discards any RTs with preferences higher or equal to its own. If there are no (remaining) RTs, it can then use address records of the destination itself. Wild-card RTs are used exactly as are wild-card MXs. RT's do not "chain"; that is, it is not valid to use the RT RRs found for a host referred to by an RT. The concrete encoding is identical to the MX RR. REFERENCES and BIBLIOGRAPHY [1] Stahl, M., "Domain Administrators Guide", RFC 1032, Network Information Center, SRI International, November 1987. [2] Lottor, M., "Domain Administrators Operations Guide", RFC 1033, Network Information Center, SRI International, November, 1987. [3] Mockapetris, P., "Domain Names - Concepts and Facilities", RFC 1034, USC/Information Sciences Institute, November 1987. [4] Mockapetris, P., "Domain Names - Implementation and Specification", RFC 1035, USC/Information Sciences Institute, November 1987. [5] Spector A., and M. Kazar, "Uniting File Systems", UNIX Review, 7(3), pp. 61-69, March 1989. [6] Zahn, et al., "Network Computing Architecture", Prentice-Hall, 1989. [7] International Telegraph and Telephone Consultative Committee, Everhart, Mamakos, Ullmann & Mockapetris [Page 9] RFC 1183 New DNS RR Definitions October 1990 "Numbering Plan for the International Telephone Service", CCITT Recommendations E.163., IXth Plenary Assembly, Melbourne, 1988, Fascicle II.2 ("Blue Book"). [8] International Telegraph and Telephone Consultative Committee, "Numbering Plan for the ISDN Era", CCITT Recommendations E.164., IXth Plenary Assembly, Melbourne, 1988, Fascicle II.2 ("Blue Book"). [9] International Telegraph and Telephone Consultative Committee. "Numbering Plan Interworking in the ISDN Era", CCITT Recommendations E.166., IXth Plenary Assembly, Melbourne, 1988, Fascicle II.2 ("Blue Book"). [10] International Telegraph and Telephone Consultative Committee, "International Numbering Plan for the Public Data Networks", CCITT Recommendations X.121., IXth Plenary Assembly, Melbourne, 1988, Fascicle VIII.3 ("Blue Book"); provisional, Geneva, 1978; amended, Geneva, 1980, Malaga-Torremolinos, 1984 and Melborne, 1988. [11] Korb, J., "Standard for the Transmission of IP datagrams Over Public Data Networks", RFC 877, Purdue University, September 1983. [12] Ullmann, R., "SMTP on X.25", RFC 1090, Prime Computer, February 1989. [13] Ullmann, R., "TP/IX: The Next Internet", Prime Computer (unpublished), July 1990. [14] Mockapetris, P., "DNS Encoding of Network Names and Other Types", RFC 1101, USC/Information Sciences Institute, April 1989. Security Considerations Security issues are not addressed in this memo. Everhart, Mamakos, Ullmann & Mockapetris [Page 10] RFC 1183 New DNS RR Definitions October 1990 Authors' Addresses Craig F. Everhart Transarc Corporation The Gulf Tower 707 Grant Street Pittsburgh, PA 15219 Phone: +1 412 338 4467 EMail: [email protected] Louis A. Mamakos Network Infrastructure Group Computer Science Center University of Maryland College Park, MD 20742-2411 Phone: +1-301-405-7836 Email: [email protected] Robert Ullmann 10-30 Prime Computer, Inc. 500 Old Connecticut Path Framingham, MA 01701 Phone: +1 508 620 2800 ext 1736 Email: [email protected] Paul Mockapetris USC Information Sciences Institute 4676 Admiralty Way Marina del Rey, CA 90292 Phone: 213-822-1511 EMail: [email protected] Everhart, Mamakos, Ullmann & Mockapetris [Page 11]
Datatracker
RFC 1183
Show sidebar by default
Yes
No
Tab to show by default
Info
Contents
HTMLization configuration
HTMLize the plaintext
Plaintextify the HTML
Maximum font size
Page dependencies
Inline
Reference
Citation links
Go to reference section
Go to linked document
| ||||||||||||||||||||
| You are visitor 01402503 — GeezerVison does not store the pages you look up. Best viewed with Netscape Navigator 4.7 or Internet Explorer 6 at 800×600. No cookies required. |