GeezerVisonThe World Wide Web, restored to 800 pixels of glory. | ||||||||||||||||||||||||
| Home|About|Gaming cabinet|Archives|How it works|Starter sites | ||||||||||||||||||||||||
GeezerVison is showing datatracker.ietf.org — RFC 3305: Report from the Joint W3C/IETF URI Planning Interest Group: Uniform Resource Identifiers (URIs), URLs, and Uniform Resource Names (URNs): Clarifications and Recommendations Network Working Group M. Mealling, Ed.
Request for Comments: 3305 R. Denenberg, Ed.
Category: Informational W3C URI Interest Group
August 2002
RFC 3305 URIs, URLs, and URNs August 2002 Table of Contents 1. The W3C URI Interest Group . . . . . . . . . . . . . . . . 2 2. URI Partitioning . . . . . . . . . . . . . . . . . . . . . 2 2.1 Classical View . . . . . . . . . . . . . . . . . . . . . . 3 2.2 Contemporary View . . . . . . . . . . . . . . . . . . . . 3 2.3 Confusion . . . . . . . . . . . . . . . . . . . . . . . . 3 3. Registration . . . . . . . . . . . . . . . . . . . . . . . 4 3.1 URI Schemes . . . . . . . . . . . . . . . . . . . . . . . 4 3.1.1 Registered URI schemes . . . . . . . . . . . . . . . . . . 4 3.1.2 Unregistered URI Schemes . . . . . . . . . . . . . . . . . 4 3.1.2.1 Public Unregistered Schemes . . . . . . . . . . . . . . . 4 3.1.2.2 Private Schemes . . . . . . . . . . . . . . . . . . . . . 5 3.1.3 Registration of URI Schemes . . . . . . . . . . . . . . . 5 3.1.3.1 IETF Tree . . . . . . . . . . . . . . . . . . . . . . . . 5 3.1.3.2 Other Trees . . . . . . . . . . . . . . . . . . . . . . . 5 3.2 URN Namespaces . . . . . . . . . . . . . . . . . . . . . . 5 3.2.1 Registered URN NIDs . . . . . . . . . . . . . . . . . . . 5 3.2.2 Pending URN NIDs . . . . . . . . . . . . . . . . . . . . . 6 3.2.3 Unregistered NIDs . . . . . . . . . . . . . . . . . . . . 7 3.2.4 Registration Procedures for URN NIDs . . . . . . . . . . . 7 4. Additional URI Issues . . . . . . . . . . . . . . . . . . 7 5. Recommendations . . . . . . . . . . . . . . . . . . . . . 8 6. Security Considerations . . . . . . . . . . . . . . . . . 8 7. Acknowledgements . . . . . . . . . . . . . . . . . . . . . 8 References . . . . . . . . . . . . . . . . . . . . . . . . 9 Authors' Addresses . . . . . . . . . . . . . . . . . . . . 10 Full Copyright Statement . . . . . . . . . . . . . . . . . 11 RFC 3305 URIs, URLs, and URNs August 2002 RFC 3305 URIs, URLs, and URNs August 2002 large, it is a problem. People are not convinced that URI and URL mean the same thing, in documents where they (apparently) do. When one RFC talks about URI schemes (e.g. "URI Syntax" (RFC 2396) [12]), another talks about URL schemes (e.g. "Registration Procedures for URL Schemes" (RFC 2717) [1]), and yet another talks of URN schemes ("Architectural Principles of URN Resolution" (RFC 2276) [13]), it is natural to wonder how they difference, and how they relate to one another. While RFC 2396, section 1.2, attempts to address the distinction between URIs, URLs and URNs, it has not been successful in clearing up the confusion. RFC 3305 URIs, URLs, and URNs August 2002 RFC 3305 URIs, URLs, and URNs August 2002 o Formal: The official list of registered NIDs is kept by IANA at http://www.iana.org/assignments/urn-namespaces. At the time of publication of this RFC it lists ten registered NIDs: * 'ietf', defined by "URN Namespace for IETF Documents" (RFC 2648) [3] * 'pin', defined by "The Network Solutions Personal Internet Name (PIN): A URN Namespace for People and Organizations" (RFC 3043) [4] * 'issn' defined by "Using The ISSN as URN within an ISSN-URN Namespace" (RFC 3043) [4] * 'oid' defined by "A URN Namespace of Object Identifiers" (RFC 3061) [6] * 'newsml' defined by "URN Namespace for NewsML Resources" (RFC 3085) [7] * 'oasis' defined by "A URN Namespace for OASIS" (RFC 3121) [8] * 'xmlorg' defined by "A URN Namespace for XML.org" (RFC 3120) [9] * 'publicid' defined by "A URN Namespace for Public Identifiers" (RFC 3151) [10] * 'isbn' defined by "Using International Standard Book Numbers as Uniform Resource Names" (RFC 3187) [15] * 'nbn' defined by "Using National Bibliography Numbers as Uniform Resource Names" (RFC 3188) [16] RFC 3305 URIs, URLs, and URNs August 2002 RFC 3305 URIs, URLs, and URNs August 2002 RFC 3305 URIs, URLs, and URNs August 2002 o Leslie Daigle o Ray Denenberg o Martin Duerst o Paul Grosso o Sandro Hawke o Renato Iannella o Graham Klyne o Larry Masinter o Michael Mealling o Mark Needleman o Norman Walsh References [1] Petke, R. and I. King, "Registration Procedures for URL Scheme Names", BCP 35, RFC 2717, November 1999. [2] Masinter, L., Alvestrand, H., Zigmond, D. and R. Petke, "Guidelines for new URL Schemes", RFC 2718, November 1999. [3] Moats, R., "A URN Namespace for IETF Documents", RFC 2648, August 1999. [4] Mealling, M., "The Network Solutions Personal Internet Name (PIN): A URN Namespace for People and Organizations", RFC 3043, January 2001. [5] Rozenfeld, S., "Using The ISSN (International Serial Standard Number) as URN (Uniform Resource Names) within an ISSN-URN Namespace", RFC 3044, January 2001. [6] Mealling, M., "A URN Namespace of Object Identifiers", RFC 3061, February 2001. [7] Coates, A., Allen, D. and D. Rivers-Moore, "URN Namespace for NewsML Resources", RFC 3085, March 2001. Mealling & Denenberg Informational [Page 9] RFC 3305 URIs, URLs, and URNs August 2002 [8] Best, K. and N. Walsh, "A URN Namespace for OASIS", RFC 3121, June 2001. [9] Best, K. and N. Walsh, "A URN Namespace for XML.org", RFC 3120, June 2001. [10] Walsh, N., Cowan, J. and P. Grosso, "A URN Namespace for Public Identifiers", RFC 3151, August 2001. [11] Daigle, L., van Gulik, D., Iannella, R. and P. Faltstrom, "URN Namespace Definition Mechanisms", BCP 33, RFC 2611, June 1999. [12] Berners-Lee, T., Fielding, R. and L. Masinter, "Uniform Resource Identifiers (URI): Generic Syntax", RFC 2396, August 1998. [13] Sollins, K., "Architectural Principles of Uniform Resource Name Resolution", RFC 2276, January 1998. [14] Fielding, R., Gettys, J., Mogul, J., Nielsen, H., Masinter, L., Leach, P. and T. Berners-Lee, "Hypertext Transfer Protocol -- HTTP/1.1", RFC 2616, June 1999. [15] Hakala, J. and H. Walravens, "Using International Standard Book Numbers as Uniform Resource Names", RFC 3187, October 2001. [16] Hakala, J., "Using National Bibliography Numbers as Uniform Resource Names", RFC 3188, October 2001. Authors' Addresses Michael Mealling VeriSign, Inc. 21345 Ridgetop Circle Sterling, VA 20166 US EMail: [email protected] Ray Denenberg Library of Congress Washington, DC 20540 US EMail: [email protected] Mealling & Denenberg Informational [Page 10] RFC 3305 URIs, URLs, and URNs August 2002
Full Copyright Statement
Copyright (C) The Internet Society (2002). All Rights Reserved.
This document and translations of it may be copied and furnished to
others, and derivative works that comment on or otherwise explain it
or assist in its implementation may be prepared, copied, published
and distributed, in whole or in part, without restriction of any
kind, provided that the above copyright notice and this paragraph are
included on all such copies and derivative works. However, this
document itself may not be modified in any way, such as by removing
the copyright notice or references to the Internet Society or other
Internet organizations, except as needed for the purpose of
developing Internet standards in which case the procedures for
copyrights defined in the Internet Standards process must be
followed, or as required to translate it into languages other than
English.
The limited permissions granted above are perpetual and will not be
revoked by the Internet Society or its successors or assigns.
This document and the information contained herein is provided on an
"AS IS" basis and THE INTERNET SOCIETY AND THE INTERNET ENGINEERING
TASK FORCE DISCLAIMS ALL WARRANTIES, EXPRESS OR IMPLIED, INCLUDING
BUT NOT LIMITED TO ANY WARRANTY THAT THE USE OF THE INFORMATION
HEREIN WILL NOT INFRINGE ANY RIGHTS OR ANY IMPLIED WARRANTIES OF
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE.
Acknowledgement
Funding for the RFC Editor function is currently provided by the
Internet Society.
Mealling & Denenberg Informational [Page 11]
Datatracker
RFC 3305
Show sidebar by default
Yes
No
Tab to show by default
Info
Contents
HTMLization configuration
HTMLize the plaintext
Plaintextify the HTML
Maximum font size
Page dependencies
Inline
Reference
Citation links
Go to reference section
Go to linked document
| ||||||||||||||||||||||||
| You are visitor 01402503 — GeezerVison does not store the pages you look up. Best viewed with Netscape Navigator 4.7 or Internet Explorer 6 at 800×600. No cookies required. |