GeezerVisonThe World Wide Web, restored to 800 pixels of glory. | ||||||||||||||||||||||||||||
| Home|About|Gaming cabinet|Archives|How it works|Starter sites | ||||||||||||||||||||||||||||
GeezerVison is showing datatracker.ietf.org — RFC 4645: Initial Language Subtag Registry Network Working Group D. Ewell, Ed.
Request for Comments: 4645 Consultant
Category: Informational September 2006
RFC 4645 Initial Language Subtag Registry September 2006 RFC 4645 Initial Language Subtag Registry September 2006 assignment of a subtag were permitted during this process (for example, the [ISO3166-1] code element 'CS' was originally assigned to Czechoslovakia and is now assigned to Serbia and Montenegro). Code elements from [UN_M.49] were also included in the ILSR using the criteria above, with the following additional rules: 3. UN numeric code elements assigned to "macro-geographical (continental)" regions as of the date of adoption of [RFC4646] were added to the ILSR and thereby made valid for use in language tags. 4. The UN numeric code elements for "economic groupings" or "other groupings," and the alphanumeric code elements in Appendix X of the UN document, were not added to the ILSR. 5. The UN numeric code elements for countries or areas not associated with an assigned [ISO3166-1] alpha-2 code element were not added to the ILSR. These values are listed in Section 4 and may be requested for registration by individuals using the process defined in [RFC4646] and according to the rules described therein. Listing of these code elements in this section is not a guarantee of future registration. 6. Code elements that were withdrawn, vacated, or deprecated from [UN_M.49] as of the date of adoption of [RFC4646] were not added to the ILSR. Using the initial set of subtags described above, the tags in the [RFC3066] registry were evaluated as follows: 7. Tags in the [RFC3066] registry that were not deprecated, consisted entirely of subtags already in this document, and have the correct form and format for tags defined by [RFC4646] were converted to records of type "redundant" in the ILSR. For example, "zh-Hant" is now defined by [RFC4646] because 'zh' is an [ISO639-1] code element and 'Hant' is an [ISO15924] code element, and both are defined as subtags in the ILSR. 8. Tags in the [RFC3066] registry that contained one or more subtags that either did not match the valid registration pattern or were not otherwise defined by [RFC4646] were converted to corresponding records of type "grandfathered" in the ILSR. These records cannot become type "redundant" except by revision of [RFC4646], but may have a "Deprecated" and Ewell Informational [Page 3] RFC 4645 Initial Language Subtag Registry September 2006 "Preferred-Value" field added to them if a subsequent subtag assignment or combination of assignments renders the tag obsolete. 9. Tags in the [RFC3066] registry that had a notation that they were deprecated were converted to records of type "grandfathered" in the ILSR. The record for the grandfathered entry contains a "Deprecated" field with the most appropriate date that can be determined for when the [RFC3066] record was deprecated. The "Comments" field may optionally contain a reason for the deprecation. The "Preferred-Value" field contains a tag that replaces the value. For example, the [RFC3066] tag "art-lojban" is deprecated and thus appears as a grandfathered tag in the ILSR. Its "Deprecated" field contains the deprecation date (in this case "2003-09-02") and the "Preferred-Value" field the value "jbo". 10. The remaining tags in the [RFC3066] registry are not deprecated and have a format consistent with language tags as defined by [RFC4646] but contain subtags that are not defined in the ILSR. These subtags are eligible for registration as variants. The ILSR contains appropriate variant records for the following list of subtags, and the registered [RFC3066] tags containing these subtags were entered into the ILSR as type "redundant": 1901 (use with Prefix: de) 1996 (use with Prefix: de) nedis (use with Prefix: sl) rozaj (use with Prefix: sl) 11. All remaining [RFC3066] registered tags were converted to records of type "grandfathered" in the ILSR. Interested parties may use the registration process in [RFC4646] to attempt to register the variant subtags not already present in the Language Subtag Registry. If all of the subtags in the original tag become fully defined by the resulting registrations, then the original tag is superseded. Such tags will have their record changed from type "grandfathered" to type "redundant" in the registry. Note that previous approval of a tag under [RFC3066] is not a guarantee of approval of a variant subtag under [RFC4646]. The existing [RFC3066] tag maintains its validity, but the original reason for its registration might have become obsolete. Ewell Informational [Page 4] RFC 4645 Initial Language Subtag Registry September 2006 RFC 4645 Initial Language Subtag Registry September 2006 RFC 4645 Initial Language Subtag Registry September 2006 Full Copyright Statement Copyright (C) The Internet Society (2006). This document is subject to the rights, licenses and restrictions contained in BCP 78, and except as set forth therein, the authors retain all their rights. This document and the information contained herein are provided on an "AS IS" basis and THE CONTRIBUTOR, THE ORGANIZATION HE/SHE REPRESENTS OR IS SPONSORED BY (IF ANY), THE INTERNET SOCIETY AND THE INTERNET ENGINEERING TASK FORCE DISCLAIM ALL WARRANTIES, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO ANY WARRANTY THAT THE USE OF THE INFORMATION HEREIN WILL NOT INFRINGE ANY RIGHTS OR ANY IMPLIED WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Intellectual Property The IETF takes no position regarding the validity or scope of any Intellectual Property Rights or other rights that might be claimed to pertain to the implementation or use of the technology described in this document or the extent to which any license under such rights might or might not be available; nor does it represent that it has made any independent effort to identify any such rights. Information on the procedures with respect to rights in RFC documents can be found in BCP 78 and BCP 79. Copies of IPR disclosures made to the IETF Secretariat and any assurances of licenses to be made available, or the result of an attempt made to obtain a general license or permission for the use of such proprietary rights by implementers or users of this specification can be obtained from the IETF on-line IPR repository at http://www.ietf.org/ipr. The IETF invites any interested party to bring to its attention any copyrights, patents or patent applications, or other proprietary rights that may cover technology that may be required to implement this standard. Please address the information to the IETF at [email protected]. Acknowledgement Funding for the RFC Editor function is provided by the IETF Administrative Support Activity (IASA). Ewell Informational [Page 7]
Datatracker
RFC 4645
Show sidebar by default
Yes
No
Tab to show by default
Info
Contents
HTMLization configuration
HTMLize the plaintext
Plaintextify the HTML
Maximum font size
Page dependencies
Inline
Reference
Citation links
Go to reference section
Go to linked document
| ||||||||||||||||||||||||||||
| You are visitor 01402503 — GeezerVison does not store the pages you look up. Best viewed with Netscape Navigator 4.7 or Internet Explorer 6 at 800×600. No cookies required. |