GeezerVison is showing docs.python.org — Index — Python 3.16.0a2 documentation
Index – R
|
- report_start() (doctest.DocTestRunner method)
- report_success() (doctest.DocTestRunner method)
- REPORT_UDIFF (in module doctest)
- report_unexpected_exception() (doctest.DocTestRunner method)
- REPORTING_FLAGS (in module doctest)
-
repr
- Repr (class in reprlib)
-
repr()
-
repr() (built-in function)
- repr() (in module reprlib)
- repr1() (reprlib.Repr method)
- ReprEnum (class in enum)
-
representation
- reprfunc (C type)
-
reprlib
- Request (class in urllib.request)
- request (socketserver.BaseRequestHandler attribute)
- request() (http.client.HTTPConnection method)
- request_queue_size (socketserver.BaseServer attribute)
- request_rate() (urllib.robotparser.RobotFileParser method)
- request_uri() (in module wsgiref.util)
- request_version (http.server.BaseHTTPRequestHandler attribute)
- RequestHandlerClass (socketserver.BaseServer attribute)
- requestline (http.server.BaseHTTPRequestHandler attribute)
- Required (in module typing)
- requires (importlib.metadata.Distribution attribute)
- requires() (in module importlib.metadata)
- requires_bz2() (in module test.support)
- requires_docstrings() (in module test.support)
- requires_freebsd_version() (in module test.support)
- requires_gil_enabled() (in module test.support)
- requires_gzip() (in module test.support)
- requires_IEEE_754() (in module test.support)
- requires_limited_api() (in module test.support)
- requires_linux_version() (in module test.support)
- requires_lzma() (in module test.support)
- requires_mac_version() (in module test.support)
- requires_resource() (in module test.support)
- requires_zlib() (in module test.support)
- RERAISE (monitoring event)
- reschedule() (asyncio.Timeout method)
- reserved (zipfile.ZipInfo attribute)
- reserved word
- RESERVED_FUTURE (in module uuid)
- RESERVED_MICROSOFT (in module uuid)
- RESERVED_NCS (in module uuid)
- reset() (asyncio.Barrier method)
- reset_color_pairs() (in module curses)
- reset_mock() (unittest.mock.AsyncMock method)
- reset_peak() (in module tracemalloc)
- reset_prog_mode() (in module curses)
- reset_shell_mode() (in module curses)
- reset_tzpath() (in module zoneinfo)
- resetbuffer() (code.InteractiveConsole method)
- resetscreen() (in module turtle)
- resetty() (in module curses)
- resetwarnings() (in module warnings)
- resizable() (tkinter.Wm method)
- resize() (bytearray method)
- resize_term() (in module curses)
- resizemode() (in module turtle)
- resizeterm() (in module curses)
- resolution (datetime.date attribute)
- resolve() (pathlib.Path method)
- resolve_bases() (in module types)
- resolve_name() (in module importlib.util)
- resolveEntity() (xml.sax.handler.EntityResolver method)
-
resource
- resource_path() (importlib.resources.abc.ResourceReader method)
- ResourceDenied
- ResourceLoader (class in importlib.abc)
- ResourceReader (class in importlib.resources.abc)
- ResourceWarning
- response() (imaplib.IMAP4 method)
- ResponseNotReady
- responses (http.server.BaseHTTPRequestHandler attribute)
- restart (pdb command)
- restart_events() (bdb.Bdb method)
- restore() (in module difflib)
-
restricted
- RESTRICTED (C macro)
- restype (ctypes._CFuncPtr attribute)
- result (tkinter.simpledialog.Dialog attribute)
- result() (asyncio.Future method)
- results() (trace.Trace method)
- RESUME (opcode)
- resume_reading() (asyncio.ReadTransport method)
- resume_writing() (asyncio.BaseProtocol method)
- retr() (poplib.POP3 method)
- retrbinary() (ftplib.FTP method)
- retrlines() (ftplib.FTP method)
- RETRY (in module tkinter.messagebox)
- retry_config (ssl.SSLECHRejectedError attribute)
- RETRYCANCEL (in module tkinter.messagebox)
-
return
- Return (class in ast)
- return (pdb command)
- return_annotation (inspect.Signature attribute)
- RETURN_GENERATOR (opcode)
- return_ok() (http.cookiejar.CookiePolicy method)
- RETURN_VALUE (opcode)
- return_value (unittest.mock.Mock attribute)
- returncode (asyncio.subprocess.Process attribute)
- retval (pdb command)
- reveal_type() (in module typing)
- reverse() (array.array method)
- reverse_order() (pstats.Stats method)
- reverse_pointer (ipaddress.IPv4Address attribute)
-
reversed()
- Reversible (class in collections.abc)
- revert() (http.cookiejar.FileCookieJar method)
- rewind() (wave.Wave_read method)
-
RFC
- RFC 1123
- RFC 1321
- RFC 1422, [1]
- RFC 1494
- RFC 1521, [1], [2]
- RFC 1522, [1], [2]
- RFC 1730
- RFC 1738, [1]
- RFC 1750
- RFC 1808, [1], [2], [3], [4]
- RFC 1869, [1]
- RFC 1870
- RFC 1924
- RFC 1939, [1]
- RFC 2033
- RFC 2045, [1], [2], [3], [4], [5], [6], [7], [8], [9], [10], [11], [12], [13], [14], [15], [16], [17], [18], [19]
- RFC 2045 Section 6.8
- RFC 2046, [1], [2]
- RFC 2047, [1], [2], [3], [4], [5], [6], [7], [8], [9], [10], [11], [12], [13], [14], [15], [16], [17], [18], [19]
- RFC 2068
- RFC 2104, [1], [2], [3]
- RFC 2109, [1], [2], [3], [4], [5], [6], [7], [8], [9], [10], [11], [12], [13], [14]
- RFC 2177, [1]
- RFC 2183, [1], [2]
- RFC 2231, [1], [2], [3], [4], [5], [6], [7], [8], [9], [10], [11], [12], [13], [14], [15], [16]
- RFC 2295
- RFC 2324
- RFC 2342, [1]
- RFC 2361
- RFC 2368
- RFC 2373, [1], [2]
- RFC 2396, [1], [2], [3]
- RFC 2397
- RFC 2449
- RFC 2487
- RFC 2518
- RFC 2595, [1]
- RFC 2616, [1], [2], [3], [4], [5], [6], [7], [8]
- RFC 2616 Section 14.23
- RFC 2616 Section 5.1.2, [1]
- RFC 2640, [1], [2], [3], [4]
- RFC 2732, [1], [2]
- RFC 2774
- RFC 2818
- RFC 2821
- RFC 2822, [1], [2], [3], [4], [5], [6], [7], [8], [9], [10], [11], [12]
- RFC 2822 Section 3.3
- RFC 2964
- RFC 2965, [1], [2], [3], [4], [5], [6], [7], [8], [9], [10], [11], [12], [13], [14], [15], [16], [17], [18], [19]
- RFC 2971, [1], [2]
- RFC 3056
- RFC 3164
- RFC 3171
- RFC 3207
- RFC 3229
- RFC 3280
- RFC 3330
- RFC 3339
- RFC 3362
- RFC 3454, [1], [2], [3]
- RFC 3490, [1], [2], [3]
- RFC 3490 Section 3.1
- RFC 3491, [1]
- RFC 3492, [1]
- RFC 3493
- RFC 3501, [1], [2], [3], [4], [5], [6], [7], [8], [9], [10], [11]
- RFC 3542, [1]
- RFC 3548
- RFC 3596 Section 2.5
- RFC 3659
- RFC 3745
- RFC 3879, [1]
- RFC 3927
- RFC 3950
- RFC 3986, [1], [2], [3], [4], [5], [6], [7], [8], [9], [10], [11], [12], [13], [14], [15], [16]
- RFC 4007, [1]
- RFC 4047
- RFC 4086
- RFC 4122, [1], [2], [3], [4], [5]
- RFC 4180
- RFC 4193
- RFC 4217
- RFC 4291, [1], [2], [3], [4]
- RFC 4315
- RFC 4337
- RFC 4380
- RFC 4616, [1], [2]
- RFC 4627, [1]
- RFC 4648, [1], [2], [3], [4], [5], [6], [7], [8], [9], [10], [11], [12], [13], [14], [15], [16], [17], [18], [19], [20]
- RFC 4918, [1], [2], [3]
- RFC 4954, [1]
- RFC 5161, [1]
- RFC 5246, [1]
- RFC 5280, [1], [2], [3], [4], [5], [6], [7]
- RFC 5321, [1]
- RFC 5322, [1], [2], [3], [4], [5], [6], [7], [8], [9], [10], [11], [12], [13], [14], [15], [16], [17], [18], [19], [20], [21], [22], [23], [24], [25], [26], [27], [28], [29], [30]
- RFC 5322 Section 2.2
- RFC 5334
- RFC 5424, [1], [2], [3], [4]
- RFC 5424 Section 6
- RFC 5735
- RFC 5789
- RFC 5842, [1]
- RFC 5891
- RFC 5894
- RFC 5895
- RFC 5929
- RFC 6066, [1], [2]
- RFC 6152
- RFC 6531, [1], [2], [3], [4], [5]
- RFC 6532, [1], [2], [3], [4]
- RFC 6585, [1], [2], [3]
- RFC 6713
- RFC 6851, [1], [2]
- RFC 6855, [1], [2], [3], [4]
- RFC 6856, [1]
- RFC 7159, [1], [2]
- RFC 7230, [1]
- RFC 7301, [1], [2]
- RFC 7525
- RFC 7538
- RFC 7616, [1]
- RFC 7693
- RFC 7725
- RFC 7903
- RFC 7914
- RFC 8081
- RFC 8089
- RFC 8089 Section 3
- RFC 821, [1]
- RFC 822, [1], [2], [3], [4], [5], [6], [7], [8], [9], [10]
- RFC 8297
- RFC 8305, [1]
- RFC 8470
- RFC 850
- RFC 9110, [1], [2], [3], [4], [5], [6], [7], [8], [9], [10], [11], [12], [13], [14], [15], [16], [17], [18], [19], [20], [21], [22], [23], [24], [25], [26], [27], [28], [29], [30], [31], [32], [33], [34], [35], [36], [37], [38], [39], [40], [41], [42], [43], [44], [45], [46], [47], [48], [49], [50], [51], [52], [53], [54], [55], [56], [57]
- RFC 9112
- RFC 9239
- RFC 9258, [1]
- RFC 9309, [1]
- RFC 9512, [1]
- RFC 9559, [1]
- RFC 9562, [1], [2], [3], [4], [5], [6], [7], [8], [9], [10], [11]
- RFC 9562 Section 5.1
- RFC 9562 Section 5.10
- RFC 9562 Section 5.3
- RFC 9562 Section 5.4
- RFC 9562 Section 5.5
- RFC 9562 Section 5.6
- RFC 9562 Section 5.7
- RFC 9562 Section 5.8
- RFC 9562 Section 5.9
- RFC 9562 Section 6.10-3
- RFC 959
- RFC 9639
- RFC 9665
- RFC 9849, [1], [2]
- rfc2109 (http.cookiejar.Cookie attribute)
- rfc2109_as_netscape (http.cookiejar.DefaultCookiePolicy attribute)
- rfc2965 (http.cookiejar.CookiePolicy attribute)
- RFC_4122 (in module uuid)
- rfile (http.server.BaseHTTPRequestHandler attribute)
- rfind() (bytearray method)
- RGB() (in module ctypes.wintypes)
- rgb_to_hls() (in module colorsys)
- rgb_to_hsv() (in module colorsys)
- rgb_to_yiq() (in module colorsys)
- rglob() (pathlib.Path method)
- richcmpfunc (C type)
- RIDGE (in module tkinter)
- right (filecmp.dircmp attribute)
- RIGHT (in module tkinter)
- right() (in module turtle)
- right_list (filecmp.dircmp attribute)
- right_only (filecmp.dircmp attribute)
- RIGHTSHIFT (in module token)
- RIGHTSHIFTEQUAL (in module token)
- rindex() (bytearray method)
- rjust() (bytearray method)
-
rlcompleter
- RLIM_INFINITY (in module resource)
- RLIM_SAVED_CUR (in module resource)
- RLIM_SAVED_MAX (in module resource)
- RLIMIT_AS (in module resource)
- RLIMIT_CORE (in module resource)
- RLIMIT_CPU (in module resource)
- RLIMIT_DATA (in module resource)
- RLIMIT_FSIZE (in module resource)
- RLIMIT_KQUEUES (in module resource)
- RLIMIT_MEMLOCK (in module resource)
- RLIMIT_MSGQUEUE (in module resource)
- RLIMIT_NICE (in module resource)
- RLIMIT_NOFILE (in module resource)
- RLIMIT_NPROC (in module resource)
- RLIMIT_NPTS (in module resource)
- RLIMIT_NTHR (in module resource)
- RLIMIT_OFILE (in module resource)
- RLIMIT_PIPEBUF (in module resource)
- RLIMIT_RSS (in module resource)
- RLIMIT_RTPRIO (in module resource)
- RLIMIT_RTTIME (in module resource)
- RLIMIT_SBSIZE (in module resource)
- RLIMIT_SIGPENDING (in module resource)
- RLIMIT_STACK (in module resource)
- RLIMIT_SWAP (in module resource)
- RLIMIT_THREADS (in module resource)
- RLIMIT_UMTXP (in module resource)
- RLIMIT_VMEM (in module resource)
- RLock (class in multiprocessing)
- RLock() (multiprocessing.managers.SyncManager method)
- rmd() (ftplib.FTP method)
- rmdir() (in module os)
- rmtree() (in module shutil)
- RobotFileParser (class in urllib.robotparser)
- robots.txt
- rollback() (sqlite3.Connection method)
- rollover() (tempfile.SpooledTemporaryFile method)
- ROMAN (in module tkinter.font)
- root (pathlib.PurePath attribute)
- rotate() (collections.deque method)
- RotatingFileHandler (class in logging.handlers)
- rotation_filename() (logging.handlers.BaseRotatingHandler method)
- rotator (logging.handlers.BaseRotatingHandler attribute)
-
round
- ROUND (in module tkinter)
-
round()
- ROUND_05UP (in module decimal)
- ROUND_CEILING (in module decimal)
- ROUND_DOWN (in module decimal)
- ROUND_FLOOR (in module decimal)
- ROUND_HALF_DOWN (in module decimal)
- ROUND_HALF_EVEN (in module decimal)
- ROUND_HALF_UP (in module decimal)
- ROUND_UP (in module decimal)
- Rounded (class in decimal)
- rounding (decimal.Context attribute)
- rounds (sys.float_info attribute)
- Row (class in sqlite3)
- row_factory (sqlite3.Connection attribute)
- rowconfigure() (tkinter.Grid method)
- rowcount (sqlite3.Cursor attribute)
- RPAR (in module token)
- rpartition() (bytearray method)
- rpc_paths (xmlrpc.server.SimpleXMLRPCRequestHandler attribute)
- rpop() (poplib.POP3 method)
- RS (in module curses.ascii)
- rset() (poplib.POP3 method)
- RShift (class in ast)
- rshift() (in module operator)
- rsplit() (bytearray method)
- RSQB (in module token)
- rstrip() (bytearray method)
- rt() (in module turtle)
- RTLD_DEEPBIND (in module os)
- RTLD_GLOBAL (in module ctypes)
- RTLD_LAZY (in module os)
- RTLD_LOCAL (in module ctypes)
- RTLD_NODELETE (in module os)
- RTLD_NOLOAD (in module os)
- RTLD_NOW (in module os)
- ruler (cmd.Cmd attribute)
-
run
- run (pdb command)
- Run script
- run() (asyncio.Runner method)
- run_concurrently() (in module test.support.threading_helper)
- run_coroutine_threadsafe() (in module asyncio)
- run_docstring_examples() (in module doctest)
- run_forever() (asyncio.loop method)
- run_in_executor() (asyncio.loop method)
- run_in_subinterp() (in module test.support)
- run_module() (in module runpy)
- run_path() (in module runpy)
- run_python_until_end() (in module test.support.script_helper)
- run_script() (modulefinder.ModuleFinder method)
- run_until_complete() (asyncio.loop method)
- run_with_locale() (in module test.support)
- run_with_tz() (in module test.support)
- runcall() (bdb.Bdb method)
- runcode() (code.InteractiveInterpreter method)
- runctx() (bdb.Bdb method)
- runeval() (bdb.Bdb method)
- runfunc() (trace.Trace method)
- runInSubprocess() (in module test.support.isolation)
- Runner (class in asyncio)
- running() (concurrent.futures.Future method)
- runningInSubprocess (in module test.support.isolation)
-
runpy
- runsource() (code.InteractiveInterpreter method)
- runtime (sys._emscripten_info attribute)
- runtime_checkable() (in module typing)
- RuntimeError
- RuntimeWarning
- RUSAGE_BOTH (in module resource)
- RUSAGE_CHILDREN (in module resource)
- RUSAGE_SELF (in module resource)
- RUSAGE_THREAD (in module resource)
- RWF_APPEND (in module os)
- RWF_ATOMIC (in module os)
- RWF_DONTCACHE (in module os)
- RWF_DSYNC (in module os)
- RWF_HIPRI (in module os)
- RWF_NOSIGNAL (in module os)
- RWF_NOWAIT (in module os)
- RWF_SYNC (in module os)
|
© Copyright 2001 Python Software Foundation.
This page is licensed under the Python Software Foundation License Version 2.
Examples, recipes, and other code in the documentation are additionally licensed under the Zero Clause BSD License.
See History and License for more information.
The Python Software Foundation is a non-profit corporation.
Please donate.
Last updated on Nov 12, 2026 (21:32 UTC).
Found a bug?
Created using Sphinx 9.1.1.
|