GV

GeezerVison

The World Wide Web, restored to 800 pixels of glory.

Home|About|Gaming cabinet|Archives|How it works|Starter sites

On this site

  • Sign in
  • ActionsCI/CD and automation
  • CodespacesCloud development environments
  • All Features
  • Documentation
  • Training
  • Certifications
  • Build with Copilot
  • Customize Copilot
  • Integrations
  • Trending repos
  • GitHub Sponsors
  • Developer articles
  • Enterprises

This view

  • Original page
  • New address

GeezerVison is showing github.com — GitHub - SagerNet/quic-go: A QUIC implementation in pure go

BranchesTags
Open more actions menu
 
 

Latest commit

 

History

7,200 Commits
7,200 Commits

Folders and files

NameName
Last commit message
Last commit date
.clusterfuzzlite
.clusterfuzzlite
 
 
.githooks
.githooks
 
 
assets
assets
 
 
congestion
congestion
 
 
http3
http3
 
 
internal
internal
 
 
monotime
monotime
 
 
qlog
qlog
 
 
qlogwriter
qlogwriter
 
 
quicvarint
quicvarint
 
 
.gitignore
.gitignore
 
 
FIPS140.md
FIPS140.md
 
 
FUZZING.md
FUZZING.md
 
 
LICENSE
LICENSE
 
 
README.md
README.md
 
 
SECURITY.md
SECURITY.md
 
 
buffer_pool.go
buffer_pool.go
 
 
chrome_parrot.go
chrome_parrot.go
 
 
client.go
client.go
 
 
closed_conn.go
closed_conn.go
 
 
config.go
config.go
 
 
conn_id_generator.go
conn_id_generator.go
 
 
conn_id_manager.go
conn_id_manager.go
 
 
connection.go
connection.go
 
 
connection_logging.go
connection_logging.go
 
 
crypto_stream.go
crypto_stream.go
 
 
crypto_stream_manager.go
crypto_stream_manager.go
 
 
datagram_queue.go
datagram_queue.go
 
 
errors.go
errors.go
 
 
flow_controller_base.go
flow_controller_base.go
 
 
flow_controller_connection.go
flow_controller_connection.go
 
 
flow_controller_stream.go
flow_controller_stream.go
 
 
frame_sorter.go
frame_sorter.go
 
 
framer.go
framer.go
 
 
go.mod
go.mod
 
 
go.sum
go.sum
 
 
interface.go
interface.go
 
 
mtu_discoverer.go
mtu_discoverer.go
 
 
oss-fuzz.sh
oss-fuzz.sh
 
 
packet_packer.go
packet_packer.go
 
 
packet_packer_chaos.go
packet_packer_chaos.go
 
 
packet_unpacker.go
packet_unpacker.go
 
 
path_manager.go
path_manager.go
 
 
path_manager_outgoing.go
path_manager_outgoing.go
 
 
receive_stream.go
receive_stream.go
 
 
reformat.sh
reformat.sh
 
 
remove-unused.sh
remove-unused.sh
 
 
rename-module.sh
rename-module.sh
 
 
retransmission_queue.go
retransmission_queue.go
 
 
send_conn.go
send_conn.go
 
 
send_queue.go
send_queue.go
 
 
send_stream.go
send_stream.go
 
 
server.go
server.go
 
 
sni.go
sni.go
 
 
stateless_reset.go
stateless_reset.go
 
 
stream.go
stream.go
 
 
streams_map.go
streams_map.go
 
 
streams_map_incoming.go
streams_map_incoming.go
 
 
streams_map_outgoing.go
streams_map_outgoing.go
 
 
sys_conn.go
sys_conn.go
 
 
sys_conn_buffers.go
sys_conn_buffers.go
 
 
sys_conn_buffers_write.go
sys_conn_buffers_write.go
 
 
sys_conn_df.go
sys_conn_df.go
 
 
sys_conn_df_darwin.go
sys_conn_df_darwin.go
 
 
sys_conn_df_linux.go
sys_conn_df_linux.go
 
 
sys_conn_df_windows.go
sys_conn_df_windows.go
 
 
sys_conn_helper_darwin.go
sys_conn_helper_darwin.go
 
 
sys_conn_helper_freebsd.go
sys_conn_helper_freebsd.go
 
 
sys_conn_helper_linux.go
sys_conn_helper_linux.go
 
 
sys_conn_helper_nonlinux.go
sys_conn_helper_nonlinux.go
 
 
sys_conn_msgx_darwin.go
sys_conn_msgx_darwin.go
 
 
sys_conn_msgx_ios.go
sys_conn_msgx_ios.go
 
 
sys_conn_msgx_macos.go
sys_conn_msgx_macos.go
 
 
sys_conn_msgx_other.go
sys_conn_msgx_other.go
 
 
sys_conn_no_oob.go
sys_conn_no_oob.go
 
 
sys_conn_nobufs_other.go
sys_conn_nobufs_other.go
 
 
sys_conn_nobufs_unix.go
sys_conn_nobufs_unix.go
 
 
sys_conn_nobufs_windows.go
sys_conn_nobufs_windows.go
 
 
sys_conn_oob.go
sys_conn_oob.go
 
 
sys_conn_udp_eof_kqueue.go
sys_conn_udp_eof_kqueue.go
 
 
sys_conn_udp_eof_linux.go
sys_conn_udp_eof_linux.go
 
 
sys_conn_windows.go
sys_conn_windows.go
 
 
token_store.go
token_store.go
 
 
transport.go
transport.go
 
 

Repository files navigation

A QUIC implementation in pure Go

Documentation PkgGoDev Code Coverage Fuzzing Status

quic-go is an implementation of the QUIC protocol (RFC 9000, RFC 9001, RFC 9002) in Go. It has support for HTTP/3 (RFC 9114), including QPACK (RFC 9204) and HTTP Datagrams (RFC 9297).

In addition to these base RFCs, it also implements the following RFCs:

  • Unreliable Datagram Extension (RFC 9221)
  • Datagram Packetization Layer Path MTU Discovery (DPLPMTUD, RFC 8899)
  • QUIC Version 2 (RFC 9369)
  • QUIC Event Logging using qlog (draft-ietf-quic-qlog-main-schema and draft-ietf-quic-qlog-quic-events)
  • QUIC Stream Resets with Partial Delivery (draft-ietf-quic-reliable-stream-reset-07 and draft-ietf-quic-reliable-stream-reset-09)

Support for WebTransport over HTTP/3 (draft-ietf-webtrans-http3) is implemented in webtransport-go.

Detailed documentation can be found on quic-go.net.

FIPS 140-3

Starting with v0.60, quic-go supports use in FIPS 140-3 environments when built with Go 1.26 or newer, using Go standard library cryptography for the QUIC code paths relevant in FIPS mode; see FIPS140.md for details.

Projects using quic-go

Project Description Stars
AdGuardHome Free and open source, powerful network-wide ads & trackers blocking DNS server. GitHub Repo stars
algernon Small self-contained pure-Go web server with Lua, Markdown, HTTP/2, QUIC, Redis and PostgreSQL support GitHub Repo stars
caddy Fast, multi-platform web server with automatic HTTPS GitHub Repo stars
cloudflared A tunneling daemon that proxies traffic from the Cloudflare network to your origins GitHub Repo stars
frp A fast reverse proxy to help you expose a local server behind a NAT or firewall to the internet GitHub Repo stars
go-libp2p libp2p implementation in Go, powering Kubo (IPFS) and Lotus (Filecoin), among others GitHub Repo stars
gost A simple security tunnel written in Go GitHub Repo stars
Hysteria A powerful, lightning fast and censorship resistant proxy GitHub Repo stars
Mercure An open, easy, fast, reliable and battery-efficient solution for real-time communications GitHub Repo stars
nodepass A secure, efficient TCP/UDP tunneling solution that delivers fast, reliable access across network restrictions using pre-established TCP/QUIC/WebSocket or HTTP/2 connections. GitHub Repo stars
OONI Probe Next generation OONI Probe. Library and CLI tool. GitHub Repo stars
reverst Reverse Tunnels in Go over HTTP/3 and QUIC GitHub Repo stars
RoadRunner High-performance PHP application server, process manager written in Go and powered with plugins GitHub Repo stars
syncthing Open Source Continuous File Synchronization GitHub Repo stars
traefik The Cloud Native Application Proxy GitHub Repo stars
v2ray-core A platform for building proxies to bypass network restrictions GitHub Repo stars
YoMo Streaming Serverless Framework for Geo-distributed System GitHub Repo stars

If you'd like to see your project added to this list, please send us a PR.

Release Policy

quic-go always aims to support the latest two Go releases.

Contributing

We are always happy to welcome new contributors! We have a number of self-contained issues that are suitable for first-time contributors, they are tagged with help wanted. If you have any questions, please feel free to reach out by opening an issue or leaving a comment.

License

The code is licensed under the MIT license. The logo and brand assets are excluded from the MIT license. See assets/LICENSE.md for the full usage policy and details.

About

A QUIC implementation in pure go

Resources

Readme
MIT license

Security policy

Security policy
Activity
Custom properties

Stars

12 stars

Watchers

0 watching

Forks

26 forks
Report repository

Releases

Packages

Used by

Contributors

Languages

You are visitor 01402503 — GeezerVison does not store the pages you look up.
Best viewed with Netscape Navigator 4.7 or Internet Explorer 6 at 800×600. No cookies required.