GV

GeezerVison

The World Wide Web, restored to 800 pixels of glory.

Home|About|Gaming cabinet|Archives|How it works|Starter sites

On this site

  • Sign in
  • ActionsCI/CD and automation
  • CodespacesCloud development environments
  • All Features
  • Documentation
  • Training
  • Certifications
  • Build with Copilot
  • Customize Copilot
  • Integrations
  • Trending repos
  • GitHub Sponsors
  • Developer articles
  • Enterprises

This view

  • Original page
  • New address

GeezerVison is showing github.com — GitHub - SocialConnect/auth: :atom: Social (OAuth1\OAuth2\OpenID\OpenIDConnect) sign with PHP :shipit:

BranchesTags
Open more actions menu

Latest commit

 

History

886 Commits
886 Commits

Folders and files

NameName
Last commit message
Last commit date
.github
.github
 
 
docs
docs
 
 
example
example
 
 
src
src
 
 
tests/Test
tests/Test
 
 
.editorconfig
.editorconfig
 
 
.gitattributes
.gitattributes
 
 
.gitignore
.gitignore
 
 
.gitlab-ci.yml
.gitlab-ci.yml
 
 
.scrutinizer.yml
.scrutinizer.yml
 
 
CHANGELOG.md
CHANGELOG.md
 
 
LICENSE
LICENSE
 
 
README.md
README.md
 
 
composer.json
composer.json
 
 
phpcs.xml
phpcs.xml
 
 
phpmd.xml.dist
phpmd.xml.dist
 
 
phpstan-baseline.neon
phpstan-baseline.neon
 
 
phpstan.neon.dist
phpstan.neon.dist
 
 
phpunit.xml.dist
phpunit.xml.dist
 
 

Repository files navigation

SocialConnect Auth

Packagist License Scrutinizer Code Quality Build Status Scrutinizer Code Coverage FOSSA Status

Getting Started :: Documentation :: Demo

Open source social sign on PHP. Connect your application(s) with social network(s).

Code examples you can find in example directory

Features

  • Functional: support 30+ providers such as Facebook, Google, Twitter, GitHub, Vk and another.
  • Completely: We supports all social sign standarts: OAuth1/OAuth2/OpenID/OpenIDConnect.
  • Follow standards: We follow PSR-7/PSR-17/PSR-18 standards.
  • Modular: Use only what, that you need, see architecture overview.
  • Quality: CodeCoverage with 80%+ and We are using static analyzers.

Supported type of providers

  • OAuth1 spec RFC 5849
  • OAuth2 spec RFC 6749
  • OpenID v1 (1.1) (WIP!) spec
  • OpenID v2 spec
  • OpenID Connect (1.0) spec
    • JWT (JSON Web Token) spec RFC 7519
    • JWK (JSON Web Keys) spec RFC 7517

Supported providers

SocialConnect/Auth support 30+ providers such as Facebook, Google, Twitter, GitHub, Vk and another.

See all 30+ provider

Installation & Getting Started

There is a documentation for Installation & Getting Started

Referenced projects

  • OrgHeiglHybridAuth from @heiglandreas - Authentication-layer for your ZendFramework3 App.
  • cakephp-social-auth from @ADmad - CakePHP plugin.
  • Phalcon-module-skeleton from @ovr - There is a module for Phalcon inside project.

Versions

Version Status EOL PHP Version
3.x Current -- >= 7.4
2.x Maintenance 2020-06-01 >= 7.0
1.x EOL 2020-01-24 >= 5.5

Contributors

This project exists thanks to all the people who contribute. Contributions are welcome!

License

This project is open-sourced software licensed under the MIT License.

See the LICENSE file for more information.

FOSSA Status

About

:atom: Social (OAuth1\OAuth2\OpenID\OpenIDConnect) sign with PHP :shipit:

socialconnect.lowl.io/

Topics

facebookfacebook-logingoogle-loginmailru-loginoauthoauth-applicationoauth1oauth2openidopenid-clientopenidconnectphpsignsocialsteam-logintwittertwitter-loginyandex-login

Resources

Readme
MIT license

Contributing

Contributing
Activity
Custom properties

Stars

565 stars

Watchers

39 watching

Forks

107 forks
Report repository

Releases

Packages

Used by

Contributors

Languages

You are visitor 01402503 — GeezerVison does not store the pages you look up.
Best viewed with Netscape Navigator 4.7 or Internet Explorer 6 at 800×600. No cookies required.