GV

GeezerVison

The World Wide Web, restored to 800 pixels of glory.

Home|About|Gaming cabinet|Archives|How it works|Starter sites

On this site

  • Sign in
  • ActionsCI/CD and automation
  • CodespacesCloud development environments
  • All Features
  • Documentation
  • Training
  • Certifications
  • Build with Copilot
  • Customize Copilot
  • Integrations
  • Trending repos
  • GitHub Sponsors
  • Developer articles
  • Enterprises

This view

  • Original page
  • New address

GeezerVison is showing github.com — GitHub - apache/httpcomponents-core: Mirror of Apache HttpCore

BranchesTags
Open more actions menu

Latest commit

 

History

4,276 Commits
4,276 Commits

Folders and files

NameName
Last commit message
Last commit date
.github
.github
 
 
.mvn/wrapper
.mvn/wrapper
 
 
httpcore5-h2
httpcore5-h2
 
 
httpcore5-jackson3
httpcore5-jackson3
 
 
httpcore5-reactive
httpcore5-reactive
 
 
httpcore5-testing
httpcore5-testing
 
 
httpcore5
httpcore5
 
 
src/site
src/site
 
 
test-CA
test-CA
 
 
.asf.yaml
.asf.yaml
 
 
.gitattributes
.gitattributes
 
 
.gitignore
.gitignore
 
 
BUILDING.txt
BUILDING.txt
 
 
CODE_OF_CONDUCT.md
CODE_OF_CONDUCT.md
 
 
LICENSE.txt
LICENSE.txt
 
 
NOTICE.txt
NOTICE.txt
 
 
README.md
README.md
 
 
RELEASE_NOTES.txt
RELEASE_NOTES.txt
 
 
SECURITY.md
SECURITY.md
 
 
doap_HttpComponents_Core.rdf
doap_HttpComponents_Core.rdf
 
 
mvnw
mvnw
 
 
mvnw.cmd
mvnw.cmd
 
 
pom.xml
pom.xml
 
 

Repository files navigation

Apache HttpComponents Core

Welcome to the HttpCore component of the Apache HttpComponents project.

GitHub Actions Status Maven Central License

Building Instructions

For building from source instructions please refer to BUILDING.txt.

Dependencies

HttpCore requires Java 1.8 compatible runtime. The optional httpcore5-jackson3 module depends on Jackson 3 and requires Java 17.

Protocol conformance

  • RFC 9110 - HTTP Semantics
  • RFC 9112 - Hypertext Transfer Protocol Version 1.1 (HTTP/1.1)
  • RFC 9113 - Hypertext Transfer Protocol Version 2 (HTTP/2)
  • RFC 7541 - HPACK: Header Compression for HTTP/2
  • RFC 1945 - Hypertext Transfer Protocol -- HTTP/1.0
  • RFC 3986 - Uniform Resource Identifier (URI): Generic Syntax
  • RFC 9218 - Extensible Prioritization Scheme for HTTP
  • RFC 10008 - The HTTP QUERY Method
  • RFC 9651 - Structured Field Values for HTTP
  • RFC 9530 - Digest Fields

Licensing

Apache HttpComponents Core is licensed under the Apache License 2.0. See the files LICENSE.txt and NOTICE.txt for more information.

Contact

  • For general information visit the main project site at
    https://hc.apache.org/
  • For current status information visit the status page at
    https://hc.apache.org/status.html
  • If you want to contribute visit
    https://hc.apache.org/get-involved.html

Cryptographic Software Notice

This distribution may include software that has been designed for use with cryptographic software. The country in which you currently reside may have restrictions on the import, possession, use, and/or re-export to another country, of encryption software. BEFORE using any encryption software, please check your country's laws, regulations and policies concerning the import, possession, or use, and re-export of encryption software, to see if this is permitted. See https://www.wassenaar.org/ for more information.

The U.S. Government Department of Commerce, Bureau of Industry and Security (BIS), has classified this software as Export Commodity Control Number (ECCN) 5D002.C.1, which includes information security software using or performing cryptographic functions with asymmetric algorithms. The form and manner of this Apache Software Foundation distribution makes it eligible for export under the License Exception ENC Technology Software Unrestricted (TSU) exception (see the BIS Export Administration Regulations, Section 740.13) for both object code and source code.

The following provides more details on the included software that may be subject to export controls on cryptographic software:

Apache HttpComponents Core interfaces with the Java Secure Socket Extension (JSSE) API to provide

  • HTTPS support

Apache HttpComponents Core does not include any implementation of JSSE.

About

Mirror of Apache HttpCore

Topics

httpcomponents

Resources

Readme
Apache-2.0 license

Code of conduct

Code of conduct

Security policy

Security policy
Activity
Custom properties

Stars

367 stars

Watchers

26 watching

Forks

364 forks
Report repository

Releases

Packages

Used by

Contributors

Languages

You are visitor 01402503 — GeezerVison does not store the pages you look up.
Best viewed with Netscape Navigator 4.7 or Internet Explorer 6 at 800×600. No cookies required.