GV

GeezerVison

The World Wide Web, restored to 800 pixels of glory.

Home|About|Gaming cabinet|Archives|How it works|Starter sites

On this site

  • Sign in
  • ActionsCI/CD and automation
  • CodespacesCloud development environments
  • All Features
  • Documentation
  • Training
  • Certifications
  • Build with Copilot
  • Customize Copilot
  • Integrations
  • Trending repos
  • GitHub Sponsors
  • Developer articles
  • Enterprises

This view

  • Original page
  • New address

GeezerVison is showing github.com — GitHub - downdemo/SNET: Experimental C++20 Linux Reactor: Select/Poll/Epoll

BranchesTags
Open more actions menu

Latest commit

 

History

2 Commits
2 Commits

Folders and files

NameName
Last commit message
Last commit date
.github/workflows
.github/workflows
 
 
docs
docs
 
 
src
src
 
 
tcpdump_demo
tcpdump_demo
 
 
test
test
 
 
.gitattributes
.gitattributes
 
 
.gitignore
.gitignore
 
 
.travis.yml
.travis.yml
 
 
LICENSE
LICENSE
 
 
Makefile
Makefile
 
 
README.md
README.md
 
 

Repository files navigation

Supported Platforms SNET-CI GitHub license

Documentation

  • tcpdump
  • Network I/O mode
  • Socket API
  • I/O multiplexing API

Build

make

RFC

  • Ethernet: RFC 894, A Standard for the Transmission of IP Datagrams over Ethernet Networks
  • ARP: RFC 826, An Ethernet Address Resolution Protocol
  • PPP: RFC 1661, The Point-to-Point Protocol (PPP)
  • PPPoE: RFC 2516, A Method for Transmitting PPP Over Ethernet (PPPoE)
  • ICMPv4: RFC 792, INTERNET CONTROL MESSAGE PROTOCOL
  • ICMPv6: RFC 2463, Internet Control Message Protocol (ICMPv6)
  • IPv4: RFC 791, INTERNET PROTOCOL
  • IPv6: RFC 8200, Internet Protocol, Version 6 (IPv6) Specification
  • IANA IPv4 Address Space Registry: RFC 1466, Guidelines for Management of IP Address Space
  • Private IPv4 addresses: RFC 1918, Address Allocation for Private Internets
  • Private IPv6 addresses: RFC 4193, Unique Local IPv6 Unicast Addresses
  • NAT: RFC 2663, IP Network Address Translator (NAT) Terminology and Considerations
  • IGMPv3: RFC 3376, Internet Group Management Protocol, Version 3
  • IPSec: RFC 2401, Security Architecture for the Internet Protocol
  • PPTP: RFC 2637, Point-to-Point Tunneling Protocol (PPTP)
  • L2TP: RFC 2661, Layer Two Tunneling Protocol "L2TP"
  • TCP: RFC 793, TRANSMISSION CONTROL PROTOCOL
  • TCP Extensions: RFC 1323, TCP Extensions for High Performance
  • UDP: RFC 768, User Datagram Protocol
  • SOCKS5: RFC 1928, SOCKS Protocol Version 5
  • PNG: RFC 2083, PNG (Portable Network Graphics) Specification Version 1.0
  • JSON: RFC 7159, The JavaScript Object Notation (JSON) Data Interchange Format
  • SIP: RFC 3261, SIP: Session Initiation Protocol
  • RTP: RFC 3550, RTP: A Transport Protocol for Real-Time Applications
  • SSL: RFC 6101, The Secure Sockets Layer (SSL) Protocol Version 3.0
  • TLS 1.3: RFC 8446, The Transport Layer Security (TLS) Protocol Version 1.3
  • X.509: RFC 8017, Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) Profile
  • PKCS #1: RFC 8017, PKCS #1: RSA Cryptography Specifications Version 2.2
  • PKCS #8: RFC 5208, Public-Key Cryptography Standards (PKCS) #8: Private-Key Information Syntax Specification Version 1.2
  • PKCS #12: RFC 7972, PKCS #12: Personal Information Exchange Syntax v1.1
  • HTTP/1.1: RFC 7230, Hypertext Transfer Protocol (HTTP/1.1): Message Syntax and Routing
  • HTTP/2: RFC 7540, Hypertext Transfer Protocol Version 2 (HTTP/2)
  • HTTP/3: RFC 9114, HTTP/3
  • QUIC: RFC 9000, QUIC: A UDP-Based Multiplexed and Secure Transport
  • HTTPS: RFC 2818, HTTP Over TLS
  • WebSocket: RFC 6455, The WebSocket Protocol
  • TELNET: RFC 854, TELNET PROTOCOL SPECIFICATION
  • SSH: RFC 4254, The Secure Shell (SSH) Connection Protocol
  • DNS: RFC 1034, DOMAIN NAMES
  • DHCP: RFC 2131, Dynamic Host Configuration Protocol
  • NTP: RFC 1305, Network Time Protocol (Version 3)
  • TZif: RFC 8536, The Time Zone Information Format (TZif)
  • FTP: RFC 959, FILE TRANSFER PROTOCOL (FTP)
  • NFSv4.2: RFC 7862, Network File System (NFS) Version 4 Minor Version 2 Protocol
  • NNTP: RFC 977, Network News Transfer Protocol
  • POP3: RFC 1939, Post Office Protocol - Version 3
  • IMAP4: RFC 1730, INTERNET MESSAGE ACCESS PROTOCOL - VERSION 4
  • SMTP: RFC 2821, Simple Mail Transfer Protocol

About

Experimental C++20 Linux Reactor: Select/Poll/Epoll

downdemo.github.io/SNET/

Topics

computer-networksepoll

Resources

Readme
MIT license
Activity

Stars

30 stars

Watchers

0 watching

Forks

10 forks
Report repository

Releases

Packages

Used by

Contributors

Languages

You are visitor 01402503 — GeezerVison does not store the pages you look up.
Best viewed with Netscape Navigator 4.7 or Internet Explorer 6 at 800×600. No cookies required.