GV

GeezerVison

The World Wide Web, restored to 800 pixels of glory.

Home|About|Gaming cabinet|Archives|How it works|Starter sites

On this site

  • Sign in
  • ActionsCI/CD and automation
  • CodespacesCloud development environments
  • All Features
  • Documentation
  • Training
  • Certifications
  • Build with Copilot
  • Customize Copilot
  • Integrations
  • Trending repos
  • GitHub Sponsors
  • Developer articles
  • Enterprises

This view

  • Original page
  • New address

GeezerVison is showing github.com — GitHub - feixiao/rfc: webrtc相关rfc学习翻译以及实现整理

BranchesTags
Open more actions menu

Latest commit

 

History

7 Commits
7 Commits

Folders and files

NameName
Last commit message
Last commit date
rfc4566
rfc4566
 
 
rfc5245
rfc5245
 
 
LICENSE
LICENSE
 
 
README.md
README.md
 
 

Repository files navigation

rfc

rfc学习翻译以及实现整理

RTP

协议

  • RFC 3550 - RTP: A Transport Protocol for Real-Time Applications

  • RFC3551 - RTP Profile for Audio and Video Conferences with Minimal Control

  • RFC3611 - RTP Control Protocol Extended Reports (RTCP XR)

  • RFC3711 - The Secure Real-time Transport Protocol (SRTP) 

  • RFC4585 - Extended RTP Profile for Real-time Transport Control Protocol (RTCP)-Based Feedback (RTP/AVPF) 

  • RFC5124 - Extended Secure RTP Profile for Real-time Transport Control Protocol (RTCP)-Based Feedback (RTP/SAVPF) 

  • RFC7741 - RTP Payload Format for VP8 Video

  • RFC6184 - RTP Payload Format for H.264 Video

  • RFC4566 - SDP: Session Description Protocol

  • RFC 5450 - Transmission Time Offsets in RTP Streams

  • RFC 5104 - Codec Control Messages in the RTP Audio-Visual Profile with Feedback (AVPF) 

    ​

开源实现

  • ortp C语言实现。

  • jrtp C++实现。

Interactive Connectivity Establishment (ICE)

协议

  • RFC 5245 - Interactive Connectivity Establishment (ICE): A Protocol for Network Address Translator (NAT) Traversal for Offer/Answer Protocols
  • RFC 3489 - STUN - Simple Traversal of User Datagram Protocol (UDP) Through Network Address Translators (NATs)
  • RFC 5389 - Session Traversal Utilities for NAT (STUN)
  • RFC 5766 - Traversal Using Relays around NAT (TURN): Relay Extensions to Session Traversal Utilities for NAT (STUN)

开源实现

  • libnice

STUN & TURN

协议

  • RFC 3489 - STUN - Simple Traversal of User Datagram Protocol (UDP) Through Network Address Translators (NATs)
  • RFC 5389 - Session Traversal Utilities for NAT (STUN)
  • RFC 5766 - Traversal Using Relays around NAT (TURN): Relay Extensions to Session Traversal Utilities for NAT (STUN)

开源实现

  • Trickle ICE 用于测试STUN/TURN服务器 的工具

  • coturn 开源的STUN/TURN服务器 服务器

    ​

About

webrtc相关rfc学习翻译以及实现整理

Topics

rfc

Resources

Readme
Apache-2.0 license
Activity

Stars

26 stars

Watchers

2 watching

Forks

5 forks
Report repository

Releases

Packages

Contributors

You are visitor 01402503 — GeezerVison does not store the pages you look up.
Best viewed with Netscape Navigator 4.7 or Internet Explorer 6 at 800×600. No cookies required.