GV

GeezerVison

The World Wide Web, restored to 800 pixels of glory.

Home|About|Gaming cabinet|Archives|How it works|Starter sites

On this site

  • Sign in
  • ActionsCI/CD and automation
  • CodespacesCloud development environments
  • All Features
  • Documentation
  • Training
  • Certifications
  • Build with Copilot
  • Customize Copilot
  • Integrations
  • Trending repos
  • GitHub Sponsors
  • Developer articles
  • Enterprises

This view

  • Original page
  • New address

GeezerVison is showing github.com — GitHub - lyndonbauto/tinkerpop: Apache TinkerPop - a graph computing framework

BranchesTags
Open more actions menu
 
 

Latest commit

 

History

19,771 Commits
19,771 Commits

Folders and files

NameName
Last commit message
Last commit date
.github
.github
 
 
bin
bin
 
 
data
data
 
 
docker
docker
 
 
docs
docs
 
 
gremlin-annotations
gremlin-annotations
 
 
gremlin-archetype
gremlin-archetype
 
 
gremlin-console
gremlin-console
 
 
gremlin-core
gremlin-core
 
 
gremlin-dotnet
gremlin-dotnet
 
 
gremlin-driver
gremlin-driver
 
 
gremlin-go
gremlin-go
 
 
gremlin-groovy
gremlin-groovy
 
 
gremlin-javascript
gremlin-javascript
 
 
gremlin-language
gremlin-language
 
 
gremlin-python
gremlin-python
 
 
gremlin-server
gremlin-server
 
 
gremlin-shaded
gremlin-shaded
 
 
gremlin-test
gremlin-test
 
 
gremlin-tools
gremlin-tools
 
 
gremlin-util
gremlin-util
 
 
gremlint
gremlint
 
 
hadoop-gremlin
hadoop-gremlin
 
 
licenses
licenses
 
 
neo4j-gremlin
neo4j-gremlin
 
 
spark-gremlin
spark-gremlin
 
 
sparql-gremlin
sparql-gremlin
 
 
tinkergraph-gremlin
tinkergraph-gremlin
 
 
.asf.yaml
.asf.yaml
 
 
.dockerignore
.dockerignore
 
 
.gitignore
.gitignore
 
 
.mailmap
.mailmap
 
 
.travis.install-maven.sh
.travis.install-maven.sh
 
 
CHANGELOG.asciidoc
CHANGELOG.asciidoc
 
 
CONTRIBUTING.asciidoc
CONTRIBUTING.asciidoc
 
 
LICENSE
LICENSE
 
 
NOTICE
NOTICE
 
 
README.asciidoc
README.asciidoc
 
 
pom.xml
pom.xml
 
 
source-release.xml
source-release.xml
 
 

Repository files navigation

TinkerPop3

gremlin driver?color=brightgreen Gremlin gremlinpython?color=brightgreen gremlin?color=brightgreen github.com%2Fapache%2Ftinkerpop%2Fgremlin go%2Fv3

badge

TinkerPop3

Documentation

Apache TinkerPop™ provides graph computing capabilities for both graph databases (OLTP) and graph analytic systems (OLAP).

  • homepage (downloads)

  • reference documentation

  • core javadoc

  • full javadoc

Building and Testing

TinkerPop uses Maven and requires Java 11 for proper building and proper operations. To build, execute unit tests and package Gremlin Console/Server run:

mvn clean install

Please see the Building on Windows section for Windows specific build instructions.

The zip distributions can be found in the following directories:

  1. gremlin-server/target

  2. gremlin-console/target

Please see the CONTRIBUTING.asciidoc file for more detailed information and options for building, test running and developing TinkerPop.

Get Started

Download Gremlin Console (compatible with Java 8/11) and unzip to a directory, then:

$ bin/gremlin.sh

         \,,,/
         (o o)
-----oOOo-(3)-oOOo-----
plugin activated: tinkerpop.server
plugin activated: tinkerpop.utilities
plugin activated: tinkerpop.tinkergraph
gremlin> graph = TinkerFactory.createModern()
==>tinkergraph[vertices:6 edges:6]
gremlin> g = traversal().withEmbedded(graph)
==>graphtraversalsource[tinkergraph[vertices:6 edges:6], standard]
gremlin> g.V().has('name','vadas').valueMap()
==>[name:[vadas], age:[27]]

About

Apache TinkerPop - a graph computing framework

tinkerpop.apache.org/

Resources

Readme
Apache-2.0 license

Code of conduct

Code of conduct

Contributing

Contributing

Security policy

Security policy
Activity

Stars

5 stars

Watchers

0 watching

Forks

0 forks
Report repository

Releases

Packages

Used by

Contributors

Languages

You are visitor 01402520 — GeezerVison does not store the pages you look up.
Best viewed with Netscape Navigator 4.7 or Internet Explorer 6 at 800×600. No cookies required.