GV

GeezerVison

The World Wide Web, restored to 800 pixels of glory.

Home|About|Gaming cabinet|Archives|How it works|Starter sites

On this site

  • Sign in
  • ActionsCI/CD and automation
  • CodespacesCloud development environments
  • All Features
  • Documentation
  • Training
  • Certifications
  • Build with Copilot
  • Customize Copilot
  • Integrations
  • Trending repos
  • GitHub Sponsors
  • Developer articles
  • Enterprises

This view

  • Original page
  • New address

GeezerVison is showing github.com — GitHub - lysine-dev/okhttp: A meticulous HTTP client for the JVM, Android, and GraalVM.

BranchesTags
Open more actions menu

Latest commit

 

History

6,511 Commits
6,511 Commits

Folders and files

NameName
Last commit message
Last commit date
.devcontainer
.devcontainer
 
 
.github
.github
 
 
.idea
.idea
 
 
.junit.run
.junit.run
 
 
.vscode
.vscode
 
 
android-test-app
android-test-app
 
 
android-test
android-test
 
 
build-logic
build-logic
 
 
docs
docs
 
 
fuzzing
fuzzing
 
 
gradle
gradle
 
 
kotlin-js-store
kotlin-js-store
 
 
maven-tests
maven-tests
 
 
mockwebserver-deprecated
mockwebserver-deprecated
 
 
mockwebserver-junit4
mockwebserver-junit4
 
 
mockwebserver-junit5
mockwebserver-junit5
 
 
mockwebserver
mockwebserver
 
 
module-tests
module-tests
 
 
native-image-tests
native-image-tests
 
 
okcurl
okcurl
 
 
okhttp-bom
okhttp-bom
 
 
okhttp-brotli
okhttp-brotli
 
 
okhttp-coroutines
okhttp-coroutines
 
 
okhttp-dnsoverhttps
okhttp-dnsoverhttps
 
 
okhttp-hpacktests
okhttp-hpacktests
 
 
okhttp-idna-mapping-table
okhttp-idna-mapping-table
 
 
okhttp-java-net-cookiejar
okhttp-java-net-cookiejar
 
 
okhttp-logging-interceptor
okhttp-logging-interceptor
 
 
okhttp-osgi-tests
okhttp-osgi-tests
 
 
okhttp-sse
okhttp-sse
 
 
okhttp-testing-support
okhttp-testing-support
 
 
okhttp-tls
okhttp-tls
 
 
okhttp-urlconnection
okhttp-urlconnection
 
 
okhttp-zstd
okhttp-zstd
 
 
okhttp
okhttp
 
 
regression-test
regression-test
 
 
samples
samples
 
 
.editorconfig
.editorconfig
 
 
.gitattributes
.gitattributes
 
 
.gitignore
.gitignore
 
 
.gitmodules
.gitmodules
 
 
BUG-BOUNTY.md
BUG-BOUNTY.md
 
 
CHANGELOG.md
CHANGELOG.md
 
 
CONTRIBUTING.md
CONTRIBUTING.md
 
 
LICENSE.txt
LICENSE.txt
 
 
README.md
README.md
 
 
build.gradle.kts
build.gradle.kts
 
 
deploy_website.sh
deploy_website.sh
 
 
gradle.properties
gradle.properties
 
 
gradlew
gradlew
 
 
gradlew.bat
gradlew.bat
 
 
mkdocs.yml
mkdocs.yml
 
 
settings.gradle.kts
settings.gradle.kts
 
 
test_docs.sh
test_docs.sh
 
 

Repository files navigation

OkHttp

See the project website for documentation and APIs.

HTTP is the way modern applications network. It’s how we exchange data & media. Doing HTTP efficiently makes your stuff load faster and saves bandwidth.

OkHttp is an HTTP client that’s efficient by default:

  • HTTP/2 support allows all requests to the same host to share a socket.
  • Connection pooling reduces request latency (if HTTP/2 isn’t available).
  • Transparent GZIP shrinks download sizes.
  • Response caching avoids the network completely for repeat requests.

OkHttp perseveres when the network is troublesome: it will silently recover from common connection problems. If your service has multiple IP addresses, OkHttp will attempt alternate addresses if the first connect fails. This is necessary for IPv4+IPv6 and services hosted in redundant data centers. OkHttp supports modern TLS features (TLS 1.3, ALPN, certificate pinning). It can be configured to fall back for broad connectivity.

Using OkHttp is easy. Its request/response API is designed with fluent builders and immutability. It supports both synchronous blocking calls and async calls with callbacks.

A well behaved user agent

OkHttp follows modern HTTP specifications such as

  • HTTP Semantics - RFC 9110
  • HTTP Caching- RFC 9111
  • HTTP/1.1 - RFC 9112
  • HTTP/2 - RFC 9113
  • Websockets - RFC 6455
  • SSE - Server-sent events

Where the spec is ambiguous, OkHttp follows modern user agents such as popular Browsers or common HTTP Libraries.

OkHttp is principled and avoids being overly configurable, especially when such configuration is to workaround a buggy server, test invalid scenarios or that contradict the relevant RFC. Other HTTP libraries exist that fill that gap allowing extensive customisation including potentially invalid requests.

Example Limitations

  • Does not allow GET with a body.
  • Cache is not an interface with alternative implementations.

Get a URL

This program downloads a URL and prints its contents as a string. Full source.

OkHttpClient client = new OkHttpClient();

String run(String url) throws IOException {
  Request request = new Request.Builder()
      .url(url)
      .build();

  try (Response response = client.newCall(request).execute()) {
    return response.body().string();
  }
}

Post to a Server

This program posts data to a service. Full source.

public static final MediaType JSON = MediaType.get("application/json");

OkHttpClient client = new OkHttpClient();

String post(String url, String json) throws IOException {
  RequestBody body = RequestBody.create(json, JSON);
  Request request = new Request.Builder()
      .url(url)
      .post(body)
      .build();
  try (Response response = client.newCall(request).execute()) {
    return response.body().string();
  }
}

Further examples are on the OkHttp Recipes page.

Requirements

OkHttp works on Android 5.0+ (API level 21+) and Java 8+.

On Android, OkHttp uses AndroidX Startup. If you disable the initializer in the manifest, then apps are responsible for calling OkHttp.initialize(applicationContext) in Application.onCreate.

OkHttp depends on Okio for high-performance I/O and the Kotlin standard library. Both are small libraries with strong backward-compatibility.

We highly recommend you keep OkHttp up-to-date. As with auto-updating web browsers, staying current with HTTPS clients is an important defense against potential security problems. We track the dynamic TLS ecosystem and adjust OkHttp to improve connectivity and security.

OkHttp uses your platform's built-in TLS implementation. On Java platforms OkHttp also supports Conscrypt, which integrates BoringSSL with Java. OkHttp will use Conscrypt if it is the first security provider:

Security.insertProviderAt(Conscrypt.newProvider(), 1);

The OkHttp 3.12.x branch supports Android 2.3+ (API level 9+) and Java 7+. These platforms lack support for TLS 1.2 and should not be used.

Releases

Our change log has release history.

The latest release is available on Maven Central.

implementation("com.squareup.okhttp3:okhttp:5.5.1")

Snapshot builds are available. R8 and ProGuard rules are available.

Also, we have a bill of materials (BOM) available to help you keep OkHttp artifacts up to date and be sure about version compatibility.

    dependencies {
       // define a BOM and its version
       implementation(platform("com.squareup.okhttp3:okhttp-bom:5.5.1"))

       // define any required OkHttp artifacts without version
       implementation("com.squareup.okhttp3:okhttp")
       implementation("com.squareup.okhttp3:logging-interceptor")
    }

Maven and JVM Projects

OkHttp is published as a Kotlin Multiplatform project. While Gradle handles this automatically, Maven projects must select between okhttp-jvm and okhttp-android. The okhttp artifact will be empty in Maven projects.

<dependencyManagement>
  <dependencies>
    <dependency>
      <groupId>com.squareup.okhttp3</groupId>
      <artifactId>okhttp-bom</artifactId>
      <version>5.2.0</version>
      <type>pom</type>
      <scope>import</scope>
    </dependency>
  </dependencies>
</dependencyManagement>
<dependency>
  <groupId>com.squareup.okhttp3</groupId>
  <artifactId>okhttp-jvm</artifactId>
  <!-- Remove after OkHttp 5.2.0 with updated BOM. -->
  <version>5.1.0</version>
</dependency>

<dependency>
  <groupId>com.squareup.okhttp3</groupId>
  <artifactId>mockwebserver3</artifactId>
</dependency>

<dependency>
  <groupId>com.squareup.okhttp3</groupId>
  <artifactId>logging-interceptor</artifactId>
</dependency>

MockWebServer

OkHttp includes a library for testing HTTP, HTTPS, and HTTP/2 clients.

The latest release is available on Maven Central.

testImplementation("com.squareup.okhttp3:mockwebserver3:5.5.1")

MockWebServer is used for firstly for internal testing, and for basic testing of apps using OkHttp client. It is not a full featured HTTP testing library that is developed standalone. It is not being actively developed for new features. As such you might find your needs outgrow MockWebServer and you may which to use a more full featured testing library such as MockServer.

GraalVM Native Image

Building your native images with GraalVM should work automatically.

See the okcurl module for an example build.

$ ./gradlew okcurl:nativeImage
$ ./okcurl/build/graal/okcurl https://httpbin.org/get

Java Modules

OkHttp (5.2+) implements Java 9 Modules.

With this in place Java builds should fail if apps attempt to use internal packages.

error: package okhttp3.internal.platform is not visible
    okhttp3.internal.platform.Platform.get();
                    ^
  (package okhttp3.internal.platform is declared in module okhttp3,
    which does not export it to module com.bigco.sdk)

The stable public API is based on the list of defined modules:

  • okhttp3
  • okhttp3.brotli
  • okhttp3.coroutines
  • okhttp3.dnsoverhttps
  • okhttp3.java.net.cookiejar
  • okhttp3.logging
  • okhttp3.sse
  • okhttp3.tls
  • okhttp3.urlconnection
  • mockwebserver3
  • mockwebserver3.junit4
  • mockwebserver3.junit5

License

Copyright 2019 Square, Inc.

Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
You may obtain a copy of the License at

   http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing, software
distributed under the License is distributed on an "AS IS" BASIS,
WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
See the License for the specific language governing permissions and
limitations under the License.

About

A meticulous HTTP client for the JVM, Android, and GraalVM.

lysine.dev/okhttp/

Topics

androidgraalvmjavakotlin

Resources

Readme
Apache-2.0 license

Contributing

Contributing
Activity
Custom properties

Stars

47.1k stars

Watchers

1.6k watching

Forks

9.3k forks
Report repository

Releases

Used by

Contributors

Languages

You are visitor 01402503 — GeezerVison does not store the pages you look up.
Best viewed with Netscape Navigator 4.7 or Internet Explorer 6 at 800×600. No cookies required.