GV

GeezerVison

The World Wide Web, restored to 800 pixels of glory.

Home|About|Gaming cabinet|Archives|How it works|Starter sites

On this site

  • Sign in
  • ActionsCI/CD and automation
  • CodespacesCloud development environments
  • All Features
  • Documentation
  • Training
  • Certifications
  • Build with Copilot
  • Customize Copilot
  • Integrations
  • Trending repos
  • GitHub Sponsors
  • Developer articles
  • Enterprises

This view

  • Original page
  • New address

GeezerVison is showing github.com — GitHub - obgm/libcoap: A CoAP (RFC 7252) implementation in C

BranchesTags
Open more actions menu

Latest commit

 

History

3,465 Commits
3,465 Commits

Folders and files

NameName
Last commit message
Last commit date
.github
.github
 
 
build-env
build-env
 
 
cmake
cmake
 
 
doc
doc
 
 
examples
examples
 
 
ext
ext
 
 
include
include
 
 
m4
m4
 
 
man
man
 
 
scripts
scripts
 
 
src
src
 
 
tests
tests
 
 
win32
win32
 
 
zephyr
zephyr
 
 
.gitignore
.gitignore
 
 
.gitmodules
.gitmodules
 
 
.pre-commit-config.yaml
.pre-commit-config.yaml
 
 
.travis.yml
.travis.yml
 
 
AUTHORS
AUTHORS
 
 
BUILDING
BUILDING
 
 
CMakeLists.txt
CMakeLists.txt
 
 
CONTRIBUTE
CONTRIBUTE
 
 
COPYING
COPYING
 
 
ChangeLog
ChangeLog
 
 
Dockerfile
Dockerfile
 
 
HOWTO.dual.gnutls
HOWTO.dual.gnutls
 
 
HOWTO.dual.openssl
HOWTO.dual.openssl
 
 
HOWTO.dual.softhsm2
HOWTO.dual.softhsm2
 
 
HOWTO.pkcs11
HOWTO.pkcs11
 
 
LICENSE
LICENSE
 
 
Makefile.am
Makefile.am
 
 
Makefile.libcoap
Makefile.libcoap
 
 
NEWS
NEWS
 
 
README
README
 
 
README.md
README.md
 
 
SECURITY.md
SECURITY.md
 
 
TODO
TODO
 
 
autogen.sh
autogen.sh
 
 
cmake-format.yaml
cmake-format.yaml
 
 
cmake_coap_config.h.in
cmake_coap_config.h.in
 
 
cmake_coap_defines.h.in
cmake_coap_defines.h.in
 
 
coap_config.h.contiki
coap_config.h.contiki
 
 
coap_config.h.riot
coap_config.h.riot
 
 
coap_config.h.windows
coap_config.h.windows
 
 
configure.ac
configure.ac
 
 
get_config.sh
get_config.sh
 
 
libcoap-3.map
libcoap-3.map
 
 
libcoap-3.pc.in
libcoap-3.pc.in
 
 
libcoap-3.sym
libcoap-3.sym
 
 

Repository files navigation

libcoap: A C implementation of the Constrained Application Protocol (RFC 7252)

Build Status: develop Static Analysis Fuzzing Status CIFuzz Status pre-commit

Copyright (C) 2010—2026 by Olaf Bergmann [email protected] and others

ABOUT LIBCOAP

libcoap is a C implementation of a lightweight application-protocol for devices that are constrained their resources such as computing power, RF range, memory, bandwidth, or network packet sizes. This protocol, CoAP, is standardized by the IETF as RFC 7252. For further information related to CoAP, see https://coap.space or CoAP Wiki.

You might want to check out libcoap-minimal for usage examples.

DOCUMENTATION

Documentation and further information can be found at https://libcoap.net.

PACKAGE CONTENTS

This package contains a protocol parser and basic networking functions for platforms with support for malloc() and BSD-style sockets. In addition, there is support for Contiki-NG, Espressif/ESP-IDF, LwIP and RIOT-OS hosted environments.

The following RFCs are supported

  • RFC7252: The Constrained Application Protocol (CoAP)

  • RFC7390: Group Communication for the Constrained Application Protocol (CoAP)

  • RFC7641: Observing Resources in the Constrained Application Protocol (CoAP)

  • RFC7959: Block-Wise Transfers in the Constrained Application Protocol (CoAP)

  • RFC7967: Constrained Application Protocol (CoAP) Option for No Server Response

  • RFC8132: PATCH and FETCH Methods for the Constrained Application Protocol (CoAP)

  • RFC8323: CoAP (Constrained Application Protocol) over TCP, TLS, and WebSockets

  • RFC8516: "Too Many Requests" Response Code for the Constrained Application Protocol

  • RFC8613: Object Security for Constrained RESTful Environments (OSCORE)

  • RFC8768: Constrained Application Protocol (CoAP) Hop-Limit Option

  • RFC8974: Extended Tokens and Stateless Clients in the Constrained Application Protocol (CoAP)

  • RFC9175: CoAP: Echo, Request-Tag, and Token Processing

  • RFC9177: Constrained Application Protocol (CoAP) Block-Wise Transfer Options Supporting Robust Transmission

The following Internet Draft is supported

  • I-D URI-Path abbreviation in CoAP

There is (D)TLS support for the following libraries

  • OpenSSL (Minimum version 1.1.0) [PKI, PSK and PKCS11]

  • GnuTLS (Minimum version 3.3.0) [PKI, PSK, RPK(3.6.6+) and PKCS11]

  • Mbed TLS (Minimum version 2.7.10) [PKI and PSK]

  • wolfSSL (Minimum version 5.2.0) [PKI, PSK, RPK(5.6.4+) and DTLS1.3(5.4.0+)]

  • TinyDTLS [PSK and RPK] [DTLS Only]

  • openHiTLS (Minimum version 0.4.0) [PKI and PSK]

The examples directory contain a CoAP client, CoAP Resource Directory server and a CoAP server to demonstrate the use of this library.

BUILDING

Further information can be found at https://libcoap.net/install.html and BUILDING.

LICENSE INFORMATION

This library is published as open-source software without any warranty of any kind. Use is permitted under the terms of the simplified BSD license. It includes public domain software. libcoap binaries may also include open-source software with their respective licensing terms. Please refer to LICENSE for further details.

About

A CoAP (RFC 7252) implementation in C

Resources

Readme

Security policy

Security policy
Activity

Stars

923 stars

Watchers

51 watching

Forks

482 forks
Report repository

Releases

Packages

Used by

Contributors

Languages

You are visitor 01402503 — GeezerVison does not store the pages you look up.
Best viewed with Netscape Navigator 4.7 or Internet Explorer 6 at 800×600. No cookies required.