GV

GeezerVison

The World Wide Web, restored to 800 pixels of glory.

Home|About|Gaming cabinet|Archives|How it works|Starter sites

On this site

  • Sign in
  • ActionsCI/CD and automation
  • CodespacesCloud development environments
  • All Features
  • Documentation
  • Training
  • Certifications
  • Build with Copilot
  • Customize Copilot
  • Integrations
  • Trending repos
  • GitHub Sponsors
  • Developer articles
  • Enterprises

This view

  • Original page
  • New address

GeezerVison is showing github.com — GitHub - panva/jose: JWA, JWS, JWE, JWT, JWK, JWKS for Node.js, Browser, Cloudflare Workers, Deno, Bun, and other Web-interoperable runtimes

BranchesTags
Open more actions menu

Latest commit

 

History

2,010 Commits
2,010 Commits

Folders and files

NameName
Last commit message
Last commit date
.github
.github
 
 
cookbook
cookbook
 
 
docs
docs
 
 
patches
patches
 
 
sponsor
sponsor
 
 
src
src
 
 
tap
tap
 
 
test-d
test-d
 
 
test
test
 
 
tools
tools
 
 
tsconfig
tsconfig
 
 
.electron_flags.sh
.electron_flags.sh
 
 
.gitignore
.gitignore
 
 
.node_flags.sh
.node_flags.sh
 
 
.prettierignore
.prettierignore
 
 
.prettierrc.json
.prettierrc.json
 
 
.versionrc.json
.versionrc.json
 
 
CHANGELOG.md
CHANGELOG.md
 
 
CODE_OF_CONDUCT.md
CODE_OF_CONDUCT.md
 
 
CONTRIBUTING.md
CONTRIBUTING.md
 
 
LICENSE.md
LICENSE.md
 
 
README.md
README.md
 
 
SECURITY.md
SECURITY.md
 
 
jsr.json
jsr.json
 
 
package-lock.json
package-lock.json
 
 
package.json
package.json
 
 
playwright.config.ts
playwright.config.ts
 
 
tsconfig.json
tsconfig.json
 
 
typedoc.json
typedoc.json
 
 

Repository files navigation

jose

jose is a JavaScript module for JSON Object Signing and Encryption, providing support for JSON Web Tokens (JWT), JSON Web Signature (JWS), JSON Web Encryption (JWE), JSON Web Key (JWK), JSON Web Key Set (JWKS), and more. The module is designed to work across various Web-interoperable runtimes including Node.js, browsers, Cloudflare Workers, Deno, Bun, and others.

Sponsor

Auth0 by Okta

If you want to quickly add JWT authentication to JavaScript apps, feel free to check out Auth0's JavaScript SDK and free plan. Create an Auth0 account; it's free!

💗 Help the project

Support from the community to continue maintaining and improving this module is welcome. If you find the module useful, please consider supporting the project by becoming a sponsor.

Dependencies: 0

jose has no dependencies and it exports tree-shakeable ESM1.

Documentation

jose is distributed via npmjs.com, jsr.io, jsdelivr.com, and github.com.

example ESM import1

import * as jose from 'jose'

JSON Web Tokens (JWT)

The jose module supports JSON Web Tokens (JWT) and provides functionality for signing and verifying tokens, as well as their JWT Claims Set validation.

  • JWT Claims Set Validation & Signature Verification using the jwtVerify function
    • Using a remote JSON Web Key Set (JWKS)
    • Using a local JSON Web Key Set (JWKS)
  • Signing using the SignJWT class
  • Utility functions
    • Decoding Token's Protected Header
    • Decoding JWT Claims Set prior to its validation

Encrypted JSON Web Tokens

The jose module supports encrypted JSON Web Tokens and provides functionality for encrypting and decrypting tokens, as well as their JWT Claims Set validation.

  • Decryption & JWT Claims Set Validation using the jwtDecrypt function
  • Encryption using the EncryptJWT class
  • Utility functions
    • Decoding Token's Protected Header

Key Utilities

The jose module supports importing, exporting, and generating keys and secrets in various formats, including PEM formats like SPKI, X.509 certificate, and PKCS #8, as well as JSON Web Key (JWK).

  • Key Import Functions
    • JWK Import
    • Public Key Import (SPKI)
    • Public Key Import (X.509 Certificate)
    • Private Key Import (PKCS #8)
  • Key and Secret Generation Functions
    • Asymmetric Key Pair Generation
    • Symmetric Secret Generation
  • Key Export Functions
    • JWK Export
    • Private Key Export
    • Public Key Export

JSON Web Signature (JWS)

The jose module supports digital signature and MAC computation and validation over arbitrary JWS Payloads using the JWS Compact Serialization and the flattened and general JWS JSON Serialization syntaxes (RFC 7515, Section 7).

  • Signing - Compact, Flattened JSON, General JSON
  • Verification - Compact, Flattened JSON, General JSON
    • Using a remote JSON Web Key Set (JWKS)
    • Using a local JSON Web Key Set (JWKS)
  • Utility functions
    • Decoding Token's Protected Header

JSON Web Encryption (JWE)

The jose module supports encryption and authenticated decryption of arbitrary plaintext using the JWE Compact Serialization and the flattened and general JWE JSON Serialization syntaxes (RFC 7516, Section 7).

  • Encryption - Compact, Flattened JSON, General JSON
  • Decryption - Compact, Flattened JSON, General JSON
  • Utility functions
    • Decoding Token's Protected Header

Other

The following are additional features and utilities provided by the jose module:

  • Calculating JWK Thumbprint
  • Calculating JWK Thumbprint URI
  • Verification using a JWK Embedded in a JWS Header
  • Unsecured JWT
  • JOSE Errors

Supported Runtimes

The jose module is compatible with JavaScript runtimes that support the utilized Web API globals and standard built-in objects or are Node.js.

The following runtimes are supported (this is not an exhaustive list):

  • Bun
  • Browsers
  • Cloudflare Workers
  • Deno
  • Electron
  • Node.js

Please note that certain algorithms may not be available depending on the runtime used. You can find a list of available algorithms for each runtime in the specific issue links provided above.

Supported Versions

Version Security Fixes 🔑 Other Bug Fixes 🐞 New Features ⭐ Runtime and Module type
v6.x Security Policy ✅ ✅ Universal2 ESM1

Specifications

Details
  • JSON Web Signature (JWS) - RFC7515
  • JSON Web Encryption (JWE) - RFC7516
  • JSON Web Key (JWK) - RFC7517
  • JSON Web Algorithms (JWA) - RFC7518
  • JSON Web Token (JWT) - RFC7519
  • JSON Web Key Thumbprint - RFC7638
  • JSON Web Key Thumbprint URI - RFC9278
  • JWS Unencoded Payload Option - RFC7797
  • CFRG Elliptic Curve ECDH and Signatures - RFC8037
  • Fully-Specified Algorithms for JOSE - RFC9864
  • ML-DSA for JOSE - RFC9964

The algorithm implementations in jose have been tested using test vectors from their respective specifications as well as RFC7520.

Footnotes

  1. CJS style let jose = require('jose') is possible in Node.js versions where the require(esm) feature is enabled by default (^20.19.0 || ^22.12.0 || >= 23.0.0). ↩ ↩2 ↩3

  2. Assumes runtime support of WebCryptoAPI and Fetch API ↩

About

JWA, JWS, JWE, JWT, JWK, JWKS for Node.js, Browser, Cloudflare Workers, Deno, Bun, and other Web-interoperable runtimes

Topics

browserbuncloudflare-workersdenojosejsonwebtokenjwajwejwkjwksjwsjwtnode

Resources

Readme
MIT license

Code of conduct

Code of conduct

Contributing

Contributing

Security policy

Security policy
Activity

Stars

7.9k stars

Watchers

42 watching

Forks

384 forks
Report repository

Releases

Sponsor this project

Used by

Contributors

Languages

You are visitor 01402503 — GeezerVison does not store the pages you look up.
Best viewed with Netscape Navigator 4.7 or Internet Explorer 6 at 800×600. No cookies required.