GV

GeezerVison

The World Wide Web, restored to 800 pixels of glory.

Home|About|Gaming cabinet|Archives|How it works|Starter sites

On this site

  • Sign in
  • ActionsCI/CD and automation
  • CodespacesCloud development environments
  • All Features
  • Documentation
  • Training
  • Certifications
  • Build with Copilot
  • Customize Copilot
  • Integrations
  • Trending repos
  • GitHub Sponsors
  • Developer articles
  • Enterprises

This view

  • Original page
  • New address

GeezerVison is showing github.com — bpo-19180: Updated reference for RFC 1750 and RFC 3280 by chkumar246 · Pull Request #148 · python/cpython

bpo-19180: Updated reference for RFC 1750 and RFC 3280 #148

New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Sign up for GitHub

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Merged
ncoghlan merged 1 commit into python:master from chkumar246:bpo-19180
Jun 9, 2017

Uh oh!

There was an error while loading. Please reload this page.

Merged

bpo-19180: Updated reference for RFC 1750 and RFC 3280 #148

Show file tree
Hide file tree
Changes from all commits
Commits
Show all changes
1 commit
Select commit
1da8be5
bpo-19180: Updated reference for RFC 1750 and RFC 3280
chkumar246 Feb 18, 2017
File filter
Filter by extension

Clear filters
Conversations
Failed to load comments.
Loading

Uh oh!

There was an error while loading. Please reload this page.

Jump to
Jump to file
Failed to load files.
Loading

Uh oh!

There was an error while loading. Please reload this page.

Diff view
Diff view

There are no files selected for viewing

19 changes: 8 additions & 11 deletions 19 Doc/library/ssl.rst
Show comments
View file
Open in desktop
Original file line number Diff line number Diff line change
Expand Up @@ -374,9 +374,9 @@ Certificate handling
Verify that *cert* (in decoded format as returned by
:meth:`SSLSocket.getpeercert`) matches the given *hostname*. The rules
applied are those for checking the identity of HTTPS servers as outlined
in :rfc:`2818` and :rfc:`6125`. In addition to HTTPS, this function
should be suitable for checking the identity of servers in various
SSL-based protocols such as FTPS, IMAPS, POPS and others.
in :rfc:`2818`, :rfc:`5280` and :rfc:`6125`. In addition to HTTPS, this
function should be suitable for checking the identity of servers in
various SSL-based protocols such as FTPS, IMAPS, POPS and others.

:exc:`CertificateError` is raised on failure. On success, the function
returns nothing::
Expand Down Expand Up @@ -820,7 +820,7 @@ Constants
.. data:: HAS_SNI

Whether the OpenSSL library has built-in support for the *Server Name
Indication* extension (as defined in :rfc:`4366`).
Indication* extension (as defined in :rfc:`6066`).

.. versionadded:: 3.2

Expand Down Expand Up @@ -2306,14 +2306,11 @@ successful call of :func:`~ssl.RAND_add`, :func:`~ssl.RAND_bytes` or
`RFC 1422: Privacy Enhancement for Internet Electronic Mail: Part II: Certificate-Based Key Management <https://www.ietf.org/rfc/rfc1422>`_
Steve Kent

`RFC 1750: Randomness Recommendations for Security <https://www.ietf.org/rfc/rfc1750>`_
Comment thread Outdated

@tiran tiran Apr 4, 2017

Copy link
Copy Markdown
Member

There was a problem hiding this comment.

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

This RFC is referenced in the documentation of RAND_add. You need to update both occurrences.

Sorry, something went wrong.

Uh oh!

There was an error while loading. Please reload this page.

All reactions

@chkumar246 chkumar246 Jun 3, 2017

Copy link
Copy Markdown
Contributor Author

There was a problem hiding this comment.

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

Done.

Sorry, something went wrong.

Uh oh!

There was an error while loading. Please reload this page.

All reactions
D. Eastlake et. al.
`RFC 4086: Randomness Requirements for Security <http://datatracker.ietf.org/doc/rfc4086/>`_
Donald E., Jeffrey I. Schiller

`RFC 3280: Internet X.509 Public Key Infrastructure Certificate and CRL Profile <https://www.ietf.org/rfc/rfc3280>`_
Housley et. al.

`RFC 4366: Transport Layer Security (TLS) Extensions <https://www.ietf.org/rfc/rfc4366>`_
Comment thread Outdated

@tiran tiran Apr 4, 2017

Copy link
Copy Markdown
Member

There was a problem hiding this comment.

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

RFC 6066 is the successor to 4366. Please update documentation of HAS_SNI.

Sorry, something went wrong.

Uh oh!

There was an error while loading. Please reload this page.

All reactions

@chkumar246 chkumar246 Jun 3, 2017

Copy link
Copy Markdown
Contributor Author

There was a problem hiding this comment.

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

Done

Sorry, something went wrong.

Uh oh!

There was an error while loading. Please reload this page.

All reactions
Blake-Wilson et. al.
`RFC 5280: Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) Profile <http://datatracker.ietf.org/doc/rfc5280/>`_
Comment thread Outdated

@tiran tiran Apr 4, 2017

Copy link
Copy Markdown
Member

There was a problem hiding this comment.

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

5280 is correct. Please update documentation of SSLSocket.getpeercert, too.

Sorry, something went wrong.

Uh oh!

There was an error while loading. Please reload this page.

All reactions

@chkumar246 chkumar246 Jun 3, 2017

Copy link
Copy Markdown
Contributor Author

There was a problem hiding this comment.

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

Done

Sorry, something went wrong.

Uh oh!

There was an error while loading. Please reload this page.

All reactions
D. Cooper

`RFC 5246: The Transport Layer Security (TLS) Protocol Version 1.2 <https://tools.ietf.org/html/rfc5246>`_
T. Dierks et. al.
Expand Down
2 changes: 1 addition & 1 deletion 2 Modules/_ssl.c
Show comments
View file
Open in desktop
Original file line number Diff line number Diff line change
Expand Up @@ -4481,7 +4481,7 @@ _ssl.RAND_add
Mix string into the OpenSSL PRNG state.

entropy (a float) is a lower bound on the entropy contained in
string. See RFC 1750.
string. See RFC 4086.
[clinic start generated code]*/

static PyObject *
Expand Down
2 changes: 1 addition & 1 deletion 2 Modules/clinic/_ssl.c.h
Show comments
View file
Open in desktop
Original file line number Diff line number Diff line change
Expand Up @@ -847,7 +847,7 @@ PyDoc_STRVAR(_ssl_RAND_add__doc__,
"Mix string into the OpenSSL PRNG state.\n"
"\n"
"entropy (a float) is a lower bound on the entropy contained in\n"
"string. See RFC 1750.");
"string. See RFC 4086.");

#define _SSL_RAND_ADD_METHODDEF \
{"RAND_add", (PyCFunction)_ssl_RAND_add, METH_FASTCALL, _ssl_RAND_add__doc__},
Expand Down
Add this suggestion to a batch that can be applied as a single commit. This suggestion is invalid because no changes were made to the code. Suggestions cannot be applied while the pull request is closed. Suggestions cannot be applied while viewing a subset of changes. Only one suggestion per line can be applied in a batch. Add this suggestion to a batch that can be applied as a single commit. Applying suggestions on deleted lines is not supported. You must change the existing code in this line in order to create a valid suggestion. Outdated suggestions cannot be applied. This suggestion has been applied or marked resolved. Suggestions cannot be applied from pending reviews. Suggestions cannot be applied on multi-line comments. Suggestions cannot be applied while the pull request is queued to merge. Suggestion cannot be applied right now. Please check back later.
You are visitor 01402503 — GeezerVison does not store the pages you look up.
Best viewed with Netscape Navigator 4.7 or Internet Explorer 6 at 800×600. No cookies required.