🔊Minimalist message bus implementation for internal communication with zero-allocation magic on Emit
-
Updated
May 14, 2023 - Go
GeezerVisonThe World Wide Web, restored to 800 pixels of glory. |
| Home|About|Gaming cabinet|Archives|How it works|Starter sites |
GeezerVison is showing github.com — Build software better, together
#
zero-allocHere are 32 public repositories matching this topic...Sort: Most stars
Sort options
🔊Minimalist message bus implementation for internal communication with zero-allocation magic on Emit
Extremely fast MurmurHash implementation with zero heap allocations
hashing fast dotnet dotnetcore murmurhash3 hash dotnet-core murmur murmur3 dotnet-standard murmurhash span dotnet-library dotnetstandard zero-alloc zero-allocation
💯 parse semantic version numbers, and ranges (the most often imitated original)
Highly scalable, single/multi node, sortable, predictable and incremental unique id generator with zero allocation magic on the sequential generation
go golang snowflake golang-library golang-package ksuid zero-alloc id-generator zero-allocation snowflake-alternative
Lua wrapper and sandbox for .NET.
lua-library lua csharp dotnet high-performance sandbox scripting dotnet-core lua-bindings lua-interpreter lua-wrapper zero-alloc lua-sandbox embedded-scripting
🌚 Zero allocated, structured, leveled and very pretty Golang logger
Ultra-low latency RASP for .NET 10. High-performance security engine for high-throughput apps (FinTech/Gaming) with zero-allocation architecture.
security dotnet high-performance grpc xss simd cybersecurity dotnet-core low-latency appsec avx512 xss-detection rasp zero-alloc zero-allocation sqli-injection active-defense net10
The AxonOS Consent Protocol — specification and reference implementation. no_std, zero-alloc, forbid(unsafe): bounded CBOR codec, exhaustive consent state machine, StimGuard for brain–computer interfaces. All AxonOS.
rust embedded protocol cbor consent bci mmp no-std safety-critical conformance zero-alloc neurotechnology axonos
Run C# logic in Unity PlayerLoop without MonoBehaviours. Zero-allocation, handle-based, and CancellationToken ready.
player csharp unity scheduler loop low-level zero-alloc zero-allocation cancellationtoken playerloop
Ultra-low-latency SPMC/MPMC pub/sub using stamped ring buffers. Formally sound with atomic-slots feature. no_std, zero-alloc hot path. Apache-2.0.
A high-performance HTTP server, written from scratch in Zig. Built on kqueue/epoll.
Highly scalable, single/multi node, sortable, predictable and incremental 64 bits (8 bytes) unique id generator with zero allocation magic on the sequential generation
Essential logger that avoids memory allocations
Blazing fast Emotion Dynamics based on NRC lexicons in pure Go
golang unicode library sentiment-analysis optimization ascii utf-8 text-processing nlp-library emotion-analysis vader-sentiment-analysis nrc zero-alloc nrc-emotion-lexicon koi8-r
Modern, zero-alloc, zero-dependency UUID library for Go (RFC 9562). V4, V7, Pool, Batch.
🤍 High-throughput server reactor & multi-protocol framework for Go
go golang http framework rest backend rest-api high-performance websocket-server server-framework zero-alloc zero-allocation rfc-compliant
Allocation-free FNV-1
Ultra-fast, zero-allocation JWT implementation for Go (0 B/op, 0 allocs/op). Strict RFC 7519 & RFC 8259 parser, Go 1.23+ iterators, and lock-free JWKS rotation.
go golang security jwt cryptography authentication high-performance iterators lock-free jwt-authentication zero-alloc jwks zero-allocation rfc8259 rfc7519 zero-allocations zero-allocs
A high-performance Sparse Radix Tree in Go. Optimized for nanosecond latency, minimal memory consumption, and support for multi-layered prefix queries.
Zero allocation inline xxhash in Rust
Add this topic to your repoTo associate your repository with the zero-alloc topic, visit your repo's landing page and select "manage topics." |
| You are visitor 01402503 — GeezerVison does not store the pages you look up. Best viewed with Netscape Navigator 4.7 or Internet Explorer 6 at 800×600. No cookies required. |