GeezerVisonThe World Wide Web, restored to 800 pixels of glory. |
| Home|About|Gaming cabinet|Archives|How it works|Starter sites |
GeezerVison is showing httpwg.org — 📄 HTTP Documentation Core SpecificationsThe “core” semantics of the HTTP protocol are defined by:
Those semantics are expressed “on the wire” in three ways: Later versions of HTTP offer field compression:
These RFCs collectively obsolete all preceding RFCs defining HTTP, including RFC 1945, RFC 2068, RFC 2616, RFC 2617, RFC 7230-5, and RFC 7540. Also relevant is the Structured Field Values specification, which is used in a growing number of headers and trailers:
Protocols built “on top” of HTTP should follow Best Current Practice, as documented here:
Extension RegistriesThere are a large number of HTTP extensions, including methods, status codes and headers. It’s important to note that they are all “part of” HTTP, as long as they’re listed in the appropriate registries:
Individual headers have their own registries that regulate permissible values, including:
Related SpecificationsThis is a partial list of HTTP-relevant specifications, here for convenience. For the complete list of HTTP extensions, see the relevant registry. Methods
Status Codes
Caching Extensions
Content-Related Extensions
Connection and Intermediary Extensions
Security-Related Extensions
|
| You are visitor 01402503 — GeezerVison does not store the pages you look up. Best viewed with Netscape Navigator 4.7 or Internet Explorer 6 at 800×600. No cookies required. |