GV

GeezerVison

The World Wide Web, restored to 800 pixels of glory.

Home|About|Gaming cabinet|Archives|How it works|Starter sites

On this site

  • 대문
  • 최근 바뀜
  • 요즘 화제
  • 임의 문서로
  • 사랑방
  • 사용자 모임
  • 관리 요청
  • 소개
  • 도움말
  • 정책과 지침
  • 질문방
  • 검색
  • 기부
  • 계정 만들기

This view

  • Original page
  • New address

GeezerVison is showing ko.wikipedia.org — XMPP - 위키백과, 우리 모두의 백과사전

XMPP
국제 표준RFC 6120 (Core) (2011)

RFC 6121 (IM & Presence) (2011)
RFC 7622 (Address Format) (2015)
RFC 3922 (CPIM) (2004)

RFC 3923 (Encryption) (2004)
도입일1999년(1999)
산업인스턴트 메신저
웹사이트www.xmpp.org
인터넷 프로토콜 스위트
응용 계층
  • BGP
  • DHCP
  • DNS
  • FTP
  • HTTP
  • HTTPS
  • IMAP
  • LDAP
  • MGCP
  • MQTT
  • NNTP
  • NTP
  • POP
  • ONC/RPC
  • RTP
  • RTSP
  • RIP
  • SIP
  • SMTP
  • SNMP
  • SSH
  • 텔넷
  • TLS/SSL
  • XMPP
  • 기타...
전송 계층
  • TCP
  • QUIC
  • UDP
  • DCCP
  • SCTP
  • RSVP
  • 기타...
인터넷 계층
  • IP
    • IPv4
    • IPv6
  • ARP
  • ICMP
  • ICMPv6
  • ECN
  • IGMP
  • IPsec
  • 기타...
링크 계층
  • NDP
  • OSPF
  • 터널
    • L2TP
  • PPP
  • MAC
    • 이더넷
    • DSL
    • ISDN
    • FDDI
  • 기타...
  • v
  • t
  • e

XMPP(Extensible Messaging and Presence Protocol)는 XML에 기반한 메시지 지향 미들웨어용 통신 프로토콜이다.[1] 이 프로토콜의 원래 이름은 Jabber였으며[2] Jabber 오픈 소스 커뮤니티가 1999년 개발하였다.

이점

  • 분산화: XMPP 네트워크의 구조는 전자메일과 비슷하다. 누구든지 자신만의 XMPP 서버를 구동할 수 있으며 중앙 마스터 서버는 존재하지 않는다.
  • 개방형 표준: 국제 인터넷 표준화 기구는 XMPP란 이름을 규정했다. (최신 규격은 RFC 6120 및 RFC 6121) 이 규격의 지원을 추가하기 위해 로열티가 따로 들지 않으며 개발은 단일 업체에 한정되지 않는다.
  • 역사: XMPP 기술은 1999년 이후로 사용되어 왔다. XMPP 표준의 다중 구현은 클라이언트, 서버, 구성 요소, 코드 라이브러리를 위해 존재한다.
  • 보안: XMPP 서버는 공개 XMPP 네트워크 (이를테면 회사 인트라넷)와 분리할 수 있으며 강력한 보안 (SASL, TLS를 통해)을 코어 XMPP 규격에 추가할 수 있다.
  • 유연성: 기기 간 상호 운용성을 유지하기 위해 사용자가 직접 만든 기능을 XMPP 최상단에 빌드할 수 있으며 일반 확장 기능들은 XMPP 표준 재단이 관리한다. XMPP의 응용 프로그램들은 IM을 넘어 그룹 채팅, 네트워크 관리, 콘텐츠 신디케이션, 협업 도구, 파일 공유, 게임, 원격 시스템 제어 및 감시, 지리 위치, 미들웨어, 클라우드 컴퓨팅, VoIP, 인증 서비스를 포함한다.

참조

  1. ↑ Johansson, Leif (2005년 4월 18일). “Greater NOrdic MIddleware Symposium (GNOMIS)”. Oslo: University of Stockholm. 2011년 5월 10일에 원본 문서에서 보존된 문서. 2012년 11월 14일에 확인함.  |장=이 무시됨 (도움말)
  2. ↑ Jabber Inc.

같이 보기

  • SIMPLE

외부 링크

  • (영어) XMPP 표준 재단
  • (영어) Open list of public XMPP servers
  • (영어) Jabber User Guide – End user introduction to XMPP (보관)
  • (영어) https://web.archive.org/web/20171017022544/https://ulloo.net/ - Create your virtual XMPP Server
  • (영어) IETF Publishes XMPP RFCs
  • (영어) XMPP Case Studies
  • (영어) Podcast: FLOSS 49: XMPP Peter Saint-Andre interviewed by Randal Schwartz and Leo Laporte
이 글은 소프트웨어에 관한 토막글입니다. 여러분의 지식으로 알차게 문서를 완성해 갑시다.
원본 주소 "https://ko.wikipedia.org/w/index.php?title=XMPP&oldid=40415160"
분류:
  • XMPP
  • XML 기반 표준
  • 채팅
  • 크로스 플랫폼 소프트웨어
  • 개방형 표준
  • 클라우드 표준
숨은 분류:
  • 인용 오류 - 장이 무시됨
  • 깨진 링크를 가지고 있는 문서
  • 해결되지 않은 속성이 있는 문서
  • 위키데이터 속성 P18을 사용하는 문서
  • 위키데이터 속성 P154를 사용하는 문서
  • 위키데이터 속성 P244를 사용하는 문서
  • 위키데이터 속성 P373을 사용하는 문서
  • 위키데이터 속성 P1273을 사용하는 문서
  • 위키데이터 속성 P8189를 사용하는 문서
  • 소프트웨어에 관한 토막글
  • 모든 토막글 문서
  • RFC 매직 링크를 사용하는 문서
You are visitor 01402503 — GeezerVison does not store the pages you look up.
Best viewed with Netscape Navigator 4.7 or Internet Explorer 6 at 800×600. No cookies required.