GV

GeezerVison

The World Wide Web, restored to 800 pixels of glory.

Home|About|Gaming cabinet|Archives|How it works|Starter sites

On this site

  • Sign in
  • ActionsCI/CD and automation
  • CodespacesCloud development environments
  • All Features
  • Documentation
  • Training
  • Certifications
  • Build with Copilot
  • Customize Copilot
  • Integrations
  • Trending repos
  • GitHub Sponsors
  • Developer articles
  • Enterprises

This view

  • Original page
  • New address

GeezerVison is showing github.com — GitHub - quic-go/quic-go: A production-ready QUIC implementation in pure Go

BranchesTags
Open more actions menu

Latest commit

 

History

7,397 Commits
7,397 Commits

Folders and files

NameName
Last commit message
Last commit date
.clusterfuzzlite
.clusterfuzzlite
 
 
.githooks
.githooks
 
 
.github
.github
 
 
assets
assets
 
 
example
example
 
 
http3
http3
 
 
integrationtests
integrationtests
 
 
internal
internal
 
 
interop
interop
 
 
metrics/dashboards
metrics/dashboards
 
 
qlog
qlog
 
 
qlogwriter
qlogwriter
 
 
quicvarint
quicvarint
 
 
testutils
testutils
 
 
.gitignore
.gitignore
 
 
.golangci.yml
.golangci.yml
 
 
AI-POLICY.md
AI-POLICY.md
 
 
FIPS140.md
FIPS140.md
 
 
FUZZING.md
FUZZING.md
 
 
LICENSE
LICENSE
 
 
README.md
README.md
 
 
SECURITY.md
SECURITY.md
 
 
client.go
client.go
 
 
client_test.go
client_test.go
 
 
closed_conn.go
closed_conn.go
 
 
closed_conn_test.go
closed_conn_test.go
 
 
codecov.yml
codecov.yml
 
 
config.go
config.go
 
 
config_test.go
config_test.go
 
 
conn_id_generator.go
conn_id_generator.go
 
 
conn_id_generator_test.go
conn_id_generator_test.go
 
 
conn_id_manager.go
conn_id_manager.go
 
 
conn_id_manager_test.go
conn_id_manager_test.go
 
 
conn_wrapped_test.go
conn_wrapped_test.go
 
 
connection.go
connection.go
 
 
connection_logging.go
connection_logging.go
 
 
connection_logging_test.go
connection_logging_test.go
 
 
connection_test.go
connection_test.go
 
 
crypto_stream.go
crypto_stream.go
 
 
crypto_stream_manager.go
crypto_stream_manager.go
 
 
crypto_stream_manager_test.go
crypto_stream_manager_test.go
 
 
crypto_stream_test.go
crypto_stream_test.go
 
 
datagram_queue.go
datagram_queue.go
 
 
datagram_queue_test.go
datagram_queue_test.go
 
 
errors.go
errors.go
 
 
errors_test.go
errors_test.go
 
 
flow_controller_base.go
flow_controller_base.go
 
 
flow_controller_connection.go
flow_controller_connection.go
 
 
flow_controller_connection_test.go
flow_controller_connection_test.go
 
 
flow_controller_stream.go
flow_controller_stream.go
 
 
flow_controller_stream_test.go
flow_controller_stream_test.go
 
 
flow_controller_test_helpers_test.go
flow_controller_test_helpers_test.go
 
 
frame_sorter.go
frame_sorter.go
 
 
frame_sorter_test.go
frame_sorter_test.go
 
 
framer.go
framer.go
 
 
framer_test.go
framer_test.go
 
 
go.mod
go.mod
 
 
go.sum
go.sum
 
 
interface.go
interface.go
 
 
mock_ack_frame_source_test.go
mock_ack_frame_source_test.go
 
 
mock_conn_runner_test.go
mock_conn_runner_test.go
 
 
mock_frame_source_test.go
mock_frame_source_test.go
 
 
mock_packer_test.go
mock_packer_test.go
 
 
mock_packet_handler_test.go
mock_packet_handler_test.go
 
 
mock_raw_conn_test.go
mock_raw_conn_test.go
 
 
mock_sealing_manager_test.go
mock_sealing_manager_test.go
 
 
mock_send_conn_test.go
mock_send_conn_test.go
 
 
mock_sender_test.go
mock_sender_test.go
 
 
mock_stream_control_frame_getter_test.go
mock_stream_control_frame_getter_test.go
 
 
mock_stream_frame_getter_test.go
mock_stream_frame_getter_test.go
 
 
mock_stream_sender_test.go
mock_stream_sender_test.go
 
 
mock_unpacker_test.go
mock_unpacker_test.go
 
 
mockgen.go
mockgen.go
 
 
mtu_discoverer.go
mtu_discoverer.go
 
 
mtu_discoverer_test.go
mtu_discoverer_test.go
 
 
oss-fuzz.sh
oss-fuzz.sh
 
 
packet_packer.go
packet_packer.go
 
 
packet_packer_test.go
packet_packer_test.go
 
 
packet_unpacker.go
packet_unpacker.go
 
 
packet_unpacker_test.go
packet_unpacker_test.go
 
 
path_manager.go
path_manager.go
 
 
path_manager_outgoing.go
path_manager_outgoing.go
 
 
path_manager_outgoing_test.go
path_manager_outgoing_test.go
 
 
path_manager_test.go
path_manager_test.go
 
 
quic_test.go
quic_test.go
 
 
receive_stream.go
receive_stream.go
 
 
receive_stream_test.go
receive_stream_test.go
 
 
received_packet_queue.go
received_packet_queue.go
 
 
received_packet_queue_test.go
received_packet_queue_test.go
 
 
retransmission_queue.go
retransmission_queue.go
 
 
retransmission_queue_test.go
retransmission_queue_test.go
 
 
send_conn.go
send_conn.go
 
 
send_conn_linux_test.go
send_conn_linux_test.go
 
 
send_conn_test.go
send_conn_test.go
 
 
send_queue.go
send_queue.go
 
 
send_queue_test.go
send_queue_test.go
 
 
send_stream.go
send_stream.go
 
 
send_stream_test.go
send_stream_test.go
 
 
server.go
server.go
 
 
server_test.go
server_test.go
 
 

Repository files navigation

A QUIC implementation in pure Go

Documentation PkgGoDev Code Coverage Fuzzing Status

quic-go is an implementation of the QUIC protocol (RFC 9000, RFC 9001, RFC 9002) in Go.

Other QUIC specifications:

  • Unreliable Datagram Extension (RFC 9221)
  • Datagram Packetization Layer Path MTU Discovery (DPLPMTUD, RFC 8899)
  • QUIC Version 2 (RFC 9369)
  • QUIC Event Logging using qlog (draft-ietf-quic-qlog-main-schema and draft-ietf-quic-qlog-quic-events)
  • QUIC Stream Resets with Partial Delivery (draft-ietf-quic-reliable-stream-reset-07 and draft-ietf-quic-reliable-stream-reset-09)

quic-go also supports HTTP/3 (RFC 9114).

Other HTTP/3 specifications:

  • QPACK: Field Compression for HTTP/3 (RFC 9204)
  • Extensible Prioritization Scheme for HTTP (RFC 9218)
  • HTTP Datagrams and the Capsule Protocol (RFC 9297)

Related projects:

  • webtransport-go implements WebTransport over HTTP/3 (draft-ietf-webtrans-http3).
  • masque-go implements CONNECT-UDP (RFC 9298).
  • connect-ip-go implements CONNECT-IP (RFC 9484).

Detailed documentation can be found on quic-go.net.

FIPS 140-3

Starting with v0.60, quic-go supports use in FIPS 140-3 environments when built with Go 1.26 or newer, using Go standard library cryptography for the QUIC code paths relevant in FIPS mode; see FIPS140.md for details.

Projects using quic-go

Project Description Stars
AdGuardHome Free and open source, powerful network-wide ads & trackers blocking DNS server. GitHub Repo stars
algernon Small self-contained pure-Go web server with Lua, Markdown, HTTP/2, QUIC, Redis and PostgreSQL support GitHub Repo stars
caddy Fast, multi-platform web server with automatic HTTPS GitHub Repo stars
cloudflared A tunneling daemon that proxies traffic from the Cloudflare network to your origins GitHub Repo stars
frp A fast reverse proxy to help you expose a local server behind a NAT or firewall to the internet GitHub Repo stars
go-libp2p libp2p implementation in Go, powering Kubo (IPFS) and Lotus (Filecoin), among others GitHub Repo stars
gost A simple security tunnel written in Go GitHub Repo stars
Hysteria A powerful, lightning fast and censorship resistant proxy GitHub Repo stars
Mercure An open, easy, fast, reliable and battery-efficient solution for real-time communications GitHub Repo stars
nodepass A secure, efficient TCP/UDP tunneling solution that delivers fast, reliable access across network restrictions using pre-established TCP/QUIC/WebSocket or HTTP/2 connections. GitHub Repo stars
OONI Probe Next generation OONI Probe. Library and CLI tool. GitHub Repo stars
reverst Reverse Tunnels in Go over HTTP/3 and QUIC GitHub Repo stars
RoadRunner High-performance PHP application server, process manager written in Go and powered with plugins GitHub Repo stars
syncthing Open Source Continuous File Synchronization GitHub Repo stars
traefik The Cloud Native Application Proxy GitHub Repo stars
v2ray-core A platform for building proxies to bypass network restrictions GitHub Repo stars
YoMo Streaming Serverless Framework for Geo-distributed System GitHub Repo stars

If you'd like to see your project added to this list, please send us a PR.

Release Policy

quic-go always aims to support the latest two Go releases.

Contributing

We are always happy to welcome new contributors! We have a number of self-contained issues that are suitable for first-time contributors, they are tagged with help wanted. If you have any questions, please feel free to reach out by opening an issue or leaving a comment.

Supported by

We are very grateful to the following organizations for supporting quic-go with free access to their tools:

  • Codecov: code coverage
  • CodeRabbit: AI code review
  • CodSpeed: continuous benchmarking
  • Macroscope: AI code review
  • OSS-Fuzz: continuous fuzzing

License

The code is licensed under the MIT license. The logo and brand assets are excluded from the MIT license. See assets/LICENSE.md for the full usage policy and details.

About

A production-ready QUIC implementation in pure Go

quic-go.net

Topics

gogolanghttp3protocolqlogquicquic-clientquic-server

Resources

Readme
MIT license

Security policy

Security policy
Activity
Custom properties

Stars

11.8k stars

Watchers

202 watching

Forks

1.7k forks
Report repository

Releases

Sponsor this project

Used by

Contributors

Languages

You are visitor 01402503 — GeezerVison does not store the pages you look up.
Best viewed with Netscape Navigator 4.7 or Internet Explorer 6 at 800×600. No cookies required.