GV

GeezerVison

The World Wide Web, restored to 800 pixels of glory.

Home|About|Gaming cabinet|Archives|How it works|Starter sites

On this site

  • Sign in
  • ActionsCI/CD and automation
  • CodespacesCloud development environments
  • All Features
  • Documentation
  • Training
  • Certifications
  • Build with Copilot
  • Customize Copilot
  • Integrations
  • Trending repos
  • GitHub Sponsors
  • Developer articles
  • Enterprises

This view

  • Original page
  • New address

GeezerVison is showing github.com — Build software better, together

#

lzma

Star

Here are 215 public repositories matching this topic...

Language: All
Filter by language
All 215 C 44 Python 40 C++ 25 C# 21 JavaScript 11 Rust 11 TypeScript 8 Go 7 Java 4 Perl 4
Sort: Most stars
Sort options
Most stars Fewest stars Most forks Fewest forks Recently updated Least recently updated

mcmilk / 7-Zip-zstd

Star 7.5k

7-Zip with support for Brotli, Fast-LZMA2, Lizard, LZ4, LZ5 and Zstandard

brotli zstd lz4 lzma archiver 7-zip zstandard 7z 7zip lizard lzma2 lzip flzma2 lz5
  • Updated Nov 9, 2026
  • C++

libarchive / libarchive

Star 3.7k

Multi-format archive and compression library

backup zip tar rar archiving cab posix zstd lzma iso9660 xz gz bz2 libarchive 7zip cpio xar
  • Updated Nov 10, 2026
  • C
dwarfs

mhx / dwarfs

Star 2.6k

A fast high-compression read-only file system for Linux, FreeBSD, macOS and Windows

windows macos linux freebsd fuse compression cpp filesystem archiving flac zstd lzma fuse-filesystem zpaq deduplication squashfs macfuse winfsp lrzip dwarfs
  • Updated Nov 12, 2026
  • C++

adamhathcock / sharpcompress

Star 2.6k

SharpCompress is a fully managed C# library to deal with many compression types and formats.

c-sharp compression gzip zip tar bzip2 dotnet-core lzma unrar xz 7zip lzip sharpcompress
  • Updated Nov 12, 2026
  • C#

zlib-ng / minizip-ng

Sponsor
Star 1.5k

Fork of the popular zip manipulation library found in the zlib distribution.

c windows macos linux compression encryption zip zlib bzip2 lzma xz minizip pkware disk-splitting winzip-aes
  • Updated Nov 10, 2026
  • C

p7zip-project / p7zip

Star 967

A new p7zip fork with additional codecs and improvements (forked from https://sourceforge.net/projects/sevenzip/ AND https://sourceforge.net/projects/p7zip/).

compression brotli p7zip archive zstd lz4 lzma 7zip lizard lzma2 lz5 lzham fastlzma2
  • Updated May 20, 2025
  • C
py7zr

miurahr / py7zr

Sponsor
Star 560

7zip in python3 with ZStandard, PPMd, LZMA2, LZMA1, Delta, BCJ, BZip2, and Deflate compressions, and AES encryption.

python cli library encryption aes bzip2 decompression compress lzma decryption deflate 7-zip zstandard 7zip lzma2 ppmd bcj
  • Updated Nov 1, 2026
  • Python

hzy3774 / AndroidP7zip

Star 484

An Android compress and extract library support popular compression format such as rar, zip, tar, lzma. based on p7zip.

jni lzma 7zip
  • Updated Oct 29, 2021
  • C++

mjebrahimi / EasyCompressor

Star 390

⚡An Easy-to-Use and Optimized compression library for .NET that unified several compression algorithms including LZ4, Snappy, Zstd, LZMA, Brotli, GZip, ZLib, and Deflate. This library aids in Improving Performance by Reducing Memory Usage and Bandwidth Usage. Along with a greate Performance Benchmark between different compression algorithms.

benchmarking benchmark performance compression csharp gzip dotnet optimization high-performance zlib decompression brotli snappy compress compressor zstd lz4 lzma deflate zstandard
  • Updated Dec 15, 2025
  • C#
TurboBench

powturbo / TurboBench

Star 377

Compression Benchmark

benchmark compression gzip zip huffman zlib brotli lz77 codec compressor data-compression bwt zstd lz4 lzturbo compressor-benchmark lzma huffman-compression-algorithm entropy-coder asymmetric-numeral-systems
  • Updated Nov 12, 2026
  • C++

ionescu007 / minlzma

Star 371

The Minimal LZMA (minlzma) project aims to provide a minimalistic, cross-platform, highly commented, standards-compliant C library (minlzlib) for decompressing LZMA2-encapsulated compressed data in LZMA format within an XZ container, as can be generated with Python 3.6, 7-zip, and xzutils

compression markov-chain decompression lempel-ziv lzma compression-algorithm arithmetic-coding range-coder compression-library decompression-library lzma2 decompression-implementations decompression-algorithm lzma-sdk lzmasdkoc
  • Updated Jan 13, 2022
  • C

nika-begiashvili / libarchivejs

Star 322

Archive library for browsers

nodejs browser gzip zip extract tar rar archives webassembly wasm bzip2 decompression archive lzma node-js archiver create 7zip lzma2
  • Updated Apr 28, 2024
  • JavaScript

mw99 / DataCompression

Star 302

Swift libcompression wrapper as an extension for the Data type (GZIP, ZLIB, LZFSE, LZMA, LZ4, deflate, RFC-1950, RFC-1951, RFC-1952)

swift ios compression gzip zip zlib inflate lz4 lzma deflate lzfse
  • Updated Oct 7, 2026
  • Swift

tsolomko / SWCompression

Star 278

A Swift framework for working with compression, archives and containers.

swift compression gzip zip tar zlib bzip2 lz4 lzma deflate xz 7-zip
  • Updated Jul 1, 2026
  • Swift

bodgit / sevenzip

Star 252

Golang library for dealing with 7-zip archives

golang compression archiving decompression brotli archive delta compressor zstd lz4 lzma golang-library deflate zstandard 7z 7zip decompressor lzma2 bcj2 bcj
  • Updated Oct 28, 2026
  • Go

fancycode / pylzma

Star 242

Python bindings for the LZMA library

python compression python3 python-bindings lzma python2 7z 7zip lzma2
  • Updated Feb 13, 2026
  • C

gendx / lzma-rs

Star 151

An LZMA decoder written in pure Rust

decoder codec lzma
  • Updated Jul 17, 2024
  • Rust

james34602 / UPX-Visual-Studio

Star 132

Compile UPX 3.96 and belong librarys on Visual Studio! Source also include LZMA, UCL and zlib ✒️

visual-studio packer zlib compressor upx lzma win32 ucl hackable one-click
  • Updated Sep 17, 2020
  • C

OlehKulykov / PLzmaSDK

Star 110

PLzmaSDK is (Portable, Patched, Package, cross-P-latform) Lzma SDK.

c swift compression js tarball cpp cocoapods extract tar compress lzma xz 7zip lzma2 lzma-sdk multi-volume-archives plzmasdk multi-volume
  • Updated Sep 21, 2026
  • C

Fatmike-GH / Fatpack

Star 108

A Windows PE packer for executables (x64) with LZMA compression and with full TLS (Thread Local Storage) support.

windows packer reverse-engineering executable compressor upx lzma pe-format portable-executable pe-loader pe-file exe-packer manual-mapping manualmap upx-packer thread-local-storage pe-packer manual-mapper executable-packing executable-compressor
  • Updated Oct 27, 2025
  • C

Add this topic to your repo

To associate your repository with the lzma topic, visit your repo's landing page and select "manage topics."

Learn more

You are visitor 01402503 — GeezerVison does not store the pages you look up.
Best viewed with Netscape Navigator 4.7 or Internet Explorer 6 at 800×600. No cookies required.